aboutsummaryrefslogtreecommitdiff
path: root/archivers/unmass/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-08-14 15:23:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-08-14 15:23:38 +0000
commit6f2095feebf4a78afb4eb3e783323f981335d108 (patch)
tree26b8d49eb2c586b38490e894a339ad7e79c079fb /archivers/unmass/Makefile
parentcd4a3ea32a27ac097469e46298662980a09e912c (diff)
Notes
Diffstat (limited to 'archivers/unmass/Makefile')
-rw-r--r--archivers/unmass/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/archivers/unmass/Makefile b/archivers/unmass/Makefile
new file mode 100644
index 000000000000..2d7be3b6dc86
--- /dev/null
+++ b/archivers/unmass/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: unmass
+# Date created: 14 Aug 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unmass
+PORTVERSION= 0.9
+CATEGORIES= archivers
+MASTER_SITES= http://mirex.mypage.sk/FILES/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Extract game archives such as wad, dar, mea exe's and many more
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= yes
+
+MAKE_ENV+= CXX="${CXX}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/kdev
+
+PLIST_FILES= bin/unmass
+
+post-patch:
+.for f in ma.cpp massfs.h utools.h
+ @${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|' ${WRKSRC}/src/${f}
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}_kdev \
+ ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>