aboutsummaryrefslogtreecommitdiff
path: root/archivers/unzoo
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-06-20 18:02:18 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-06-20 18:02:18 +0000
commit4d5beacc07354a67d152a2aa1ff2d50e969418bf (patch)
tree73c863331d60e7df83249c4e93f134f5fae74c9c /archivers/unzoo
parent57b08033a41938a27dd94647f2a83e87e8350b86 (diff)
downloadports-4d5beacc07354a67d152a2aa1ff2d50e969418bf.tar.gz
ports-4d5beacc07354a67d152a2aa1ff2d50e969418bf.zip
Notes
Diffstat (limited to 'archivers/unzoo')
-rw-r--r--archivers/unzoo/Makefile35
-rw-r--r--archivers/unzoo/distinfo2
-rw-r--r--archivers/unzoo/pkg-descr8
3 files changed, 45 insertions, 0 deletions
diff --git a/archivers/unzoo/Makefile b/archivers/unzoo/Makefile
new file mode 100644
index 000000000000..71ebd0fe3e00
--- /dev/null
+++ b/archivers/unzoo/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: unzoo
+# Date created: 20 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unzoo
+DISTVERSION= 4.4
+CATEGORIES= archivers
+MASTER_SITES= http://critical.ch/unzoo/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A zoo archive extractor
+
+EXTRA_DEFINES= -DSYS_IS_UNIX -DSYS_HAS_MKDIR
+
+PLIST_FILES= bin/unzoo
+
+MAN1= unzoo.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+CFLAGS+= -trigraphs
+.endif
+
+do-build:
+ ${CC} ${CFLAGS} ${EXTRA_DEFINES} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/archivers/unzoo/distinfo b/archivers/unzoo/distinfo
new file mode 100644
index 000000000000..fae68430daec
--- /dev/null
+++ b/archivers/unzoo/distinfo
@@ -0,0 +1,2 @@
+MD5 (unzoo-4.4.tar.gz) = 2e73c26188688033b7c2b6c7da32ad39
+SIZE (unzoo-4.4.tar.gz) = 26842
diff --git a/archivers/unzoo/pkg-descr b/archivers/unzoo/pkg-descr
new file mode 100644
index 000000000000..026c53a5cc3e
--- /dev/null
+++ b/archivers/unzoo/pkg-descr
@@ -0,0 +1,8 @@
+Unzoo is a zoo archive extractor written by Martin Schoenert. If unzoo is
+called with no arguments, it will first print a summary of the commands and
+then prompt for command lines interactively.
+
+WWW: http://archives.math.utk.edu/
+
+- ehaupt
+ehaupt@critical.ch