aboutsummaryrefslogtreecommitdiff
path: root/archivers/urbackup-client
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-04-15 16:17:59 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-04-15 16:17:59 +0000
commitcade70bbe110bc88a7a4fdbf03843dfe78ce1561 (patch)
treea0acea29b8ef6f6efe55d55868b0d59df580e16b /archivers/urbackup-client
parent9efedc4a0e7679b5db4f2eefce10e852942e0328 (diff)
downloadports-cade70bbe110bc88a7a4fdbf03843dfe78ce1561.tar.gz
ports-cade70bbe110bc88a7a4fdbf03843dfe78ce1561.zip
New port: archivers/urbackup-client
UrBackup is an easy to setup Open Source client/server backup system, that through a combination of image and file backups accomplishes both data safety and a fast restoration time. File and image backups are made while the system is running without interrupting current processes. UrBackup also continuously watches folders you want backed up in order to quickly find differences to previous backups. Because of that, incremental file backups are really fast. Your files can be restored through the web interface, via the client or the Windows Explorer while the backups of drive volumes can be restored with a bootable CD or USB-Stick (bare metal restore). A web interface makes setting up your own backup server really easy. WWW: https://www.urbackup.org PR: 227154 Submitted by: Kirk Coombs <freebsd@coombscloud.com>
Notes
Notes: svn path=/head/; revision=467397
Diffstat (limited to 'archivers/urbackup-client')
-rw-r--r--archivers/urbackup-client/Makefile106
-rw-r--r--archivers/urbackup-client/distinfo3
-rw-r--r--archivers/urbackup-client/files/pkg-message.in25
-rw-r--r--archivers/urbackup-client/files/urbackup_client.in30
-rw-r--r--archivers/urbackup-client/pkg-descr18
-rw-r--r--archivers/urbackup-client/pkg-plist50
6 files changed, 232 insertions, 0 deletions
diff --git a/archivers/urbackup-client/Makefile b/archivers/urbackup-client/Makefile
new file mode 100644
index 000000000000..74d3e12e8576
--- /dev/null
+++ b/archivers/urbackup-client/Makefile
@@ -0,0 +1,106 @@
+# $FreeBSD$
+
+PORTNAME= urbackup-client
+DISTVERSION= 2.2.5
+CATEGORIES= archivers
+MASTER_SITES= https://hndl.urbackup.org/Client/${DISTVERSION}/
+
+MAINTAINER= freebsd@coombscloud.com
+COMMENT= Client component of the UrBackup backup system
+
+LICENSE= AGPLv3
+
+WRKSRC= ${WRKDIR}/${DISTNAME}.0
+
+OPTIONS_DEFINE= GUI
+GUI_DESC= GTK2 Tray Icon
+OPTIONS_SUB= yes
+
+LIB_DEPENDS+= libcryptopp.so:security/cryptopp
+GUI_LIB_DEPENDS+= libwx_baseu-3.0.so:x11-toolkits/wxgtk30
+
+USERS= urbackup
+GROUPS= urbackup
+
+USES= gettext
+GNU_CONFIGURE= YES
+CPPFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
+CONFIGURE_ARGS= --disable-clientupdate
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGUI}
+USE_WX= 3.0+
+CONFIGURE_ARGS+= --with-wx-config=${WX_CONFIG}
+.else
+CONFIGURE_ARGS+= --enable-headless
+.endif
+
+USE_RC_SUBR= urbackup_client
+SUB_FILES= pkg-message
+
+CONFFILES= mariadbdump.conf \
+ mariadbxtrabackup.conf \
+ mariadbdump.conf \
+ postgresbase.conf \
+ postgresqldump.conf
+
+XPMFILES= backup-bad.xpm \
+ backup-no-recent.xpm \
+ backup-ok.xpm \
+ backup-progress.xpm \
+ backup-indexing.xpm \
+ backup-no-server.xpm \
+ backup-progress-pause.xpm
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/urbackup/scripts
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/urbackup
+ ${MKDIR} ${STAGEDIR}/var/urbackup/data
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/urbackupclientctl \
+ ${STAGEDIR}${PREFIX}/bin
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/urbackupclientbackend \
+ ${STAGEDIR}${PREFIX}/sbin
+
+ (cd ${WRKSRC}/urbackupclient/backup_scripts && ${COPYTREE_BIN} . \
+ ${STAGEDIR}${PREFIX}/share/urbackup/scripts "! -name *\.conf")
+
+.for f in ${CONFFILES}
+ ${INSTALL_DATA} ${WRKSRC}/urbackupclient/backup_scripts/${f} \
+ ${STAGEDIR}${PREFIX}/etc/urbackup/${f}.sample
+.endfor
+
+ ${INSTALL_DATA} ${WRKSRC}/client/data/updates_h.dat \
+ ${STAGEDIR}${PREFIX}/share/urbackup
+
+ ${INSTALL_MAN} ${WRKSRC}/docs/urbackupclientbackend.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-install-GUI-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/urbackupclientgui \
+ ${STAGEDIR}${PREFIX}/bin
+
+ ${INSTALL_DATA} ${WRKSRC}/client/data/logo1.png \
+ ${STAGEDIR}${PREFIX}/share/urbackup
+
+ ${INSTALL_DATA} ${WRKSRC}/client/info.txt \
+ ${STAGEDIR}${PREFIX}/share/urbackup
+
+.for f in ${XPMFILES}
+ ${INSTALL_DATA} ${WRKSRC}/client/data/${f} \
+ ${STAGEDIR}${PREFIX}/share/urbackup
+.endfor
+
+.for f in it pl pt_BR sk zh_TW zh_CN de es fr ru uk da nl fa cs
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/urbackup/lang/${f}
+.endfor
+
+.for f in it pl pt_BR sk zh_TW zh_CN de es fr ru uk da nl fa cs
+ ${INSTALL_DATA} ${WRKSRC}/client/data/lang/${f}/urbackup.mo \
+ ${STAGEDIR}${PREFIX}/share/urbackup/lang/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/archivers/urbackup-client/distinfo b/archivers/urbackup-client/distinfo
new file mode 100644
index 000000000000..0b3f5b3707c3
--- /dev/null
+++ b/archivers/urbackup-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521902273
+SHA256 (urbackup-client-2.2.5.tar.gz) = 125180db455c6dd626e1facae77bad2f92b5f2570adfa7e4beeb922f39586d2c
+SIZE (urbackup-client-2.2.5.tar.gz) = 3368914
diff --git a/archivers/urbackup-client/files/pkg-message.in b/archivers/urbackup-client/files/pkg-message.in
new file mode 100644
index 000000000000..cee4a77d05d2
--- /dev/null
+++ b/archivers/urbackup-client/files/pkg-message.in
@@ -0,0 +1,25 @@
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+
+archivers/urbackup-client includes an RC script:
+%%PREFIX%%/etc/rc.d/urbackup_client
+
+TO START URBACKUP CLIENT ON BOOT:
+sysrc urbackup_client_enable=YES
+
+START MANUALLY:
+service urbackup_client start
+
+If the GTK2 GUI was built, it can be launched via:
+%%PREFIX%%/bin/urbackupclientctl
+
+NOTE: For client configuration or to view logs, the GTK2 GUI
+needs to have one of the following in its PATH:
+ - kdesu (e.g., %%PREFIX%%/lib/kde4/libexec/)
+ (port: x11/kde-runtime)
+ - gksu (e.g., %%PREFIX%%/bin/)
+ (port: sysutils/gksu)
+
+The client can also be configured via the UrBackup Server, or
+%%PREFIX%%/bin/urbackupclientctl
+
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/archivers/urbackup-client/files/urbackup_client.in b/archivers/urbackup-client/files/urbackup_client.in
new file mode 100644
index 000000000000..d31dcbb973b6
--- /dev/null
+++ b/archivers/urbackup-client/files/urbackup_client.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: urbackup_client
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# urbackup_client_enable (bool): Set to NO by default.
+# Set it to YES to enable the UrBackup Client Backend.
+
+. /etc/rc.subr
+
+name=urbackup_client
+desc="UrBackup Client Backend"
+rcvar=urbackup_client_enable
+
+load_rc_config $name
+
+: ${urbackup_client_enable:=NO}
+
+command=%%PREFIX%%/sbin/urbackupclientbackend
+pidfile=/var/run/urbackupclientbackend.pid
+
+command_args="-d -w $pidfile"
+
+run_rc_command "$1"
diff --git a/archivers/urbackup-client/pkg-descr b/archivers/urbackup-client/pkg-descr
new file mode 100644
index 000000000000..3a9f910b1d16
--- /dev/null
+++ b/archivers/urbackup-client/pkg-descr
@@ -0,0 +1,18 @@
+UrBackup is an easy to setup Open Source client/server backup system,
+that through a combination of image and file backups accomplishes
+both data safety and a fast restoration time.
+
+File and image backups are made while the system is running without
+interrupting current processes.
+
+UrBackup also continuously watches folders you want backed up in
+order to quickly find differences to previous backups. Because of
+that, incremental file backups are really fast.
+
+Your files can be restored through the web interface, via the client or the
+Windows Explorer while the backups of drive volumes can be restored with a
+bootable CD or USB-Stick (bare metal restore).
+
+A web interface makes setting up your own backup server really easy.
+
+WWW: https://www.urbackup.org
diff --git a/archivers/urbackup-client/pkg-plist b/archivers/urbackup-client/pkg-plist
new file mode 100644
index 000000000000..3750de82f4ed
--- /dev/null
+++ b/archivers/urbackup-client/pkg-plist
@@ -0,0 +1,50 @@
+bin/urbackupclientctl
+%%GUI%%bin/urbackupclientgui
+sbin/urbackupclientbackend
+@(,,0444) man/man1/urbackupclientbackend.1.gz
+@mode 0700
+@sample etc/urbackup/mariadbdump.conf.sample
+@sample etc/urbackup/mariadbxtrabackup.conf.sample
+@sample etc/urbackup/postgresbase.conf.sample
+@sample etc/urbackup/postgresqldump.conf.sample
+share/urbackup/scripts/list
+share/urbackup/scripts/mariadbdump
+share/urbackup/scripts/mariadbpostbackup
+share/urbackup/scripts/mariadbprebackup
+share/urbackup/scripts/mariadbxtrabackup
+share/urbackup/scripts/postgresbase
+share/urbackup/scripts/postgresqldump
+share/urbackup/scripts/postgresqlpostbackup
+share/urbackup/scripts/postgresqlprebackup
+share/urbackup/scripts/restore-mariadbbackup
+share/urbackup/scripts/setup-mariadbbackup
+share/urbackup/scripts/setup-postgresbackup
+@mode 0644
+share/urbackup/updates_h.dat
+%%GUI%%share/urbackup/info.txt
+%%GUI%%share/urbackup/logo1.png
+%%GUI%%share/urbackup/backup-bad.xpm
+%%GUI%%share/urbackup/backup-indexing.xpm
+%%GUI%%share/urbackup/backup-no-recent.xpm
+%%GUI%%share/urbackup/backup-no-server.xpm
+%%GUI%%share/urbackup/backup-ok.xpm
+%%GUI%%share/urbackup/backup-progress-pause.xpm
+%%GUI%%share/urbackup/backup-progress.xpm
+%%GUI%%share/urbackup/lang/cs/urbackup.mo
+%%GUI%%share/urbackup/lang/da/urbackup.mo
+%%GUI%%share/urbackup/lang/de/urbackup.mo
+%%GUI%%share/urbackup/lang/es/urbackup.mo
+%%GUI%%share/urbackup/lang/fa/urbackup.mo
+%%GUI%%share/urbackup/lang/fr/urbackup.mo
+%%GUI%%share/urbackup/lang/it/urbackup.mo
+%%GUI%%share/urbackup/lang/nl/urbackup.mo
+%%GUI%%share/urbackup/lang/pl/urbackup.mo
+%%GUI%%share/urbackup/lang/pt_BR/urbackup.mo
+%%GUI%%share/urbackup/lang/ru/urbackup.mo
+%%GUI%%share/urbackup/lang/sk/urbackup.mo
+%%GUI%%share/urbackup/lang/uk/urbackup.mo
+%%GUI%%share/urbackup/lang/zh_CN/urbackup.mo
+%%GUI%%share/urbackup/lang/zh_TW/urbackup.mo
+@dir(,,0700) /var/urbackup/data
+@dir(urbackup,urbackup,0755) /var/urbackup
+@mode 555