aboutsummaryrefslogtreecommitdiff
path: root/archivers/wzip
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 00:03:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 00:03:49 +0000
commitd5204fb557aa9b396accc87f204cd90b2bb520a9 (patch)
tree1158f0c06de60583f1ba9dca36eea13902861b6d /archivers/wzip
parentc5965b6a01133630c6fae952e64d528f93f20998 (diff)
Notes
Diffstat (limited to 'archivers/wzip')
-rw-r--r--archivers/wzip/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/archivers/wzip/Makefile b/archivers/wzip/Makefile
index a00184acc440..1ba65a60fc7d 100644
--- a/archivers/wzip/Makefile
+++ b/archivers/wzip/Makefile
@@ -10,17 +10,16 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= onatan@gmail.com
COMMENT= Preprocessor for lossy data compression
-NO_STAGE= yes
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
post-patch:
@${REINPLACE_CMD} 's|gcc|${CC}|' ${WRKSRC}/${MAKEFILE}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>