aboutsummaryrefslogtreecommitdiff
path: root/archivers/xdms/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2005-07-11 03:44:36 +0000
committerMark Pulford <markp@FreeBSD.org>2005-07-11 03:44:36 +0000
commitcd766c325408ad30c99e7bd0d2917322aa734137 (patch)
tree6383402b26577425f7823e87b8ffa9d9cb7d1fcd /archivers/xdms/Makefile
parent23852b0daae85da2b65504a23a8a11bb08f931e6 (diff)
Notes
Diffstat (limited to 'archivers/xdms/Makefile')
-rw-r--r--archivers/xdms/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
index 001b2520bc34..27e39716553b 100644
--- a/archivers/xdms/Makefile
+++ b/archivers/xdms/Makefile
@@ -6,28 +6,26 @@
#
PORTNAME= xdms
-PORTVERSION= 1.3
+PORTVERSION= 1.3.1
CATEGORIES= archivers
-MASTER_SITES= http://www.ee.tut.fi/~heikki/xdms/
-DISTNAME= xdms
+MASTER_SITES= http://www.modeemi.fi/~shd/xdms/
MAINTAINER= markp@FreeBSD.org
COMMENT= An Amiga DMS archiver unpacker
-USE_ZIP= yes
USE_REINPLACE= yes
-WRKSRC= ${WRKDIR}/xdms/src
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
ALL_TARGET= xdms
post-patch:
- ${REINPLACE_CMD} "s@gcc@${CC}@g; s@-O3 -Wall@${CFLAGS} -Wall@g" \
- ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} "s@-O3 -Wall@-Wall@g" ${WRKSRC}/src/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xdms ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xdms ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/xdms
- ${INSTALL_DATA} ${WRKDIR}/xdms/xdms.txt ${PREFIX}/share/doc/xdms
+ ${INSTALL_DATA} ${WRKSRC}/xdms.txt ${PREFIX}/share/doc/xdms
.endif
.include <bsd.port.mk>