aboutsummaryrefslogtreecommitdiff
path: root/archivers/xdms/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-17 18:01:40 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-17 18:01:40 +0000
commitb4c49d7baab576d8be3bddedf0bf960fe032b2ba (patch)
treebc3ca4178d8ca3723ba0fbe34a83dfeb7062f4e7 /archivers/xdms/Makefile
parent54c02e5a6c0880d7876497c092ad30b98640b7e0 (diff)
downloadports-b4c49d7baab576d8be3bddedf0bf960fe032b2ba.tar.gz
ports-b4c49d7baab576d8be3bddedf0bf960fe032b2ba.zip
Notes
Diffstat (limited to 'archivers/xdms/Makefile')
-rw-r--r--archivers/xdms/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
new file mode 100644
index 000000000000..caa6c7cf4075
--- /dev/null
+++ b/archivers/xdms/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xdms
+# Date created: Apr 13, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdms
+PORTVERSION= 1.3
+CATEGORIES= archivers
+MASTER_SITES= http://www.ee.tut.fi/~o159219/xdms/
+DISTNAME= xdms
+
+MAINTAINER= mark@kyne.com.au
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/xdms/src
+ALL_TARGET= xdms
+
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g; s@-O3 -Wall@${CFLAGS} -Wall@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xdms ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xdms
+ ${INSTALL_DATA} ${WRKDIR}/xdms/xdms.txt ${PREFIX}/share/doc/xdms
+.endif
+
+.include <bsd.port.mk>