aboutsummaryrefslogtreecommitdiff
path: root/archivers/xmill
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2009-03-13 18:15:57 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2009-03-13 18:15:57 +0000
commit1a908783368153ef8dd41163028a8741ee138f09 (patch)
tree29dbe5e5d45e9147eccf0024706f60f111cdbefe /archivers/xmill
parent6d9278eb9cc38af0e07421f79c27a076428b5b7a (diff)
downloadports-1a908783368153ef8dd41163028a8741ee138f09.tar.gz
ports-1a908783368153ef8dd41163028a8741ee138f09.zip
Notes
Diffstat (limited to 'archivers/xmill')
-rw-r--r--archivers/xmill/Makefile4
-rw-r--r--archivers/xmill/files/patch-XMill-CompressMan.cpp11
-rw-r--r--archivers/xmill/files/patch-XMill-PPMDI.cpp11
3 files changed, 22 insertions, 4 deletions
diff --git a/archivers/xmill/Makefile b/archivers/xmill/Makefile
index bbcbe7ba1851..471fc06b022f 100644
--- a/archivers/xmill/Makefile
+++ b/archivers/xmill/Makefile
@@ -27,10 +27,6 @@ PORTEXAMPLES= *
.include <bsd.port.pre.mk>
-.if ( ${ARCH} == "amd64" || ${ARCH} == "sparc64" ) && ${OSVERSION} >= 700043
-BROKEN= does not compile
-.endif
-
post-patch:
# Allow to build with modern GCC
@${REINPLACE_CMD} -e 's,friend,& class,' ${WRKSRC}/XMill/*.?pp \
diff --git a/archivers/xmill/files/patch-XMill-CompressMan.cpp b/archivers/xmill/files/patch-XMill-CompressMan.cpp
new file mode 100644
index 000000000000..0df8b5694305
--- /dev/null
+++ b/archivers/xmill/files/patch-XMill-CompressMan.cpp
@@ -0,0 +1,11 @@
+--- XMill/CompressMan.cpp.orig 2009-03-13 19:11:05.000000000 +0100
++++ XMill/CompressMan.cpp 2009-03-13 19:11:08.000000000 +0100
+@@ -423,7 +423,7 @@
+ UserCompressorFactory *compressor=compressorlist;
+ while(compressor!=NULL)
+ {
+- printf("%lu =>",(unsigned int)compressor);
++ printf("%lu =>",(unsigned intptr_t)compressor);
+ printf("%s\n",compressor->GetName());
+ compressor=compressor->next;
+ }
diff --git a/archivers/xmill/files/patch-XMill-PPMDI.cpp b/archivers/xmill/files/patch-XMill-PPMDI.cpp
new file mode 100644
index 000000000000..8080202fddc5
--- /dev/null
+++ b/archivers/xmill/files/patch-XMill-PPMDI.cpp
@@ -0,0 +1,11 @@
+--- XMill/PPMDI.cpp.orig 2009-03-13 19:12:05.000000000 +0100
++++ XMill/PPMDI.cpp 2009-03-13 19:12:29.000000000 +0100
+@@ -245,7 +245,7 @@
+
+ cleanup:
+ *outused = j;
+- *inused = inlen - (int)endptr + (int)src;
++ *inused = inlen - (intptr_t)endptr + (intptr_t)src;
+ return ret;
+ }
+