aboutsummaryrefslogtreecommitdiff
path: root/archivers/zoo
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-07-01 10:27:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-07-01 10:27:06 +0000
commitf27e17c455193fdd4b103f46eb98e13cf8394f51 (patch)
treea607948e06d36e6b0c7f97fde1a77a062d760bc6 /archivers/zoo
parent26756078ea565d517eb1a889a86171151f95e8cb (diff)
downloadports-f27e17c455193fdd4b103f46eb98e13cf8394f51.tar.gz
ports-f27e17c455193fdd4b103f46eb98e13cf8394f51.zip
Really fix `archivers/zoo' on 64-bit machines. When PR 162804 had been
committed by gabor@ back in 2011, only two of the proposed four patches supplied were actually included; the patches for zoodel.c and zoopack.c were somehow missed. PR: 162804, 240982
Notes
Notes: svn path=/head/; revision=540948
Diffstat (limited to 'archivers/zoo')
-rw-r--r--archivers/zoo/Makefile2
-rw-r--r--archivers/zoo/files/patch-zoodel.c14
-rw-r--r--archivers/zoo/files/patch-zoopack.c14
3 files changed, 29 insertions, 1 deletions
diff --git a/archivers/zoo/Makefile b/archivers/zoo/Makefile
index 8ae7627f61da..feed7dbe6f77 100644
--- a/archivers/zoo/Makefile
+++ b/archivers/zoo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zoo
PORTVERSION= 2.10.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.kiarchive.ru/pub/unix/arcers/ \
LOCAL/ehaupt
diff --git a/archivers/zoo/files/patch-zoodel.c b/archivers/zoo/files/patch-zoodel.c
new file mode 100644
index 000000000000..f01eb93146e2
--- /dev/null
+++ b/archivers/zoo/files/patch-zoodel.c
@@ -0,0 +1,14 @@
+--- zoodel.c.orig 1991-07-16 15:58:46 UTC
++++ zoodel.c
+@@ -138,7 +138,11 @@ if (*option == 'g') {
+
+ /* read archive header */
+ frd_zooh (&zoo_header, zoo_file);
++#ifdef __LP64__
++ if ((int)(zoo_header.zoo_start + zoo_header.zoo_minus) != 0)
++#else
+ if ((zoo_header.zoo_start + zoo_header.zoo_minus) != 0L)
++#endif
+ prterror ('f', failed_consistency);
+ if (ver_too_high (&zoo_header))
+ prterror ('f', wrong_version, zoo_header.major_ver, zoo_header.minor_ver);
diff --git a/archivers/zoo/files/patch-zoopack.c b/archivers/zoo/files/patch-zoopack.c
new file mode 100644
index 000000000000..a3b569a2e160
--- /dev/null
+++ b/archivers/zoo/files/patch-zoopack.c
@@ -0,0 +1,14 @@
+--- zoopack.c.orig 1993-05-01 03:59:21 UTC
++++ zoopack.c
+@@ -139,7 +139,11 @@ if (zoo_file == NOFILE)
+ /* Read the header of the old archive. */
+ frd_zooh(&old_zoo_header, zoo_file);
+
++#ifdef __LP64__
++if ((int)(old_zoo_header.zoo_start + old_zoo_header.zoo_minus) != 0) {
++#else
+ if ((old_zoo_header.zoo_start + old_zoo_header.zoo_minus) != 0L) {
++#endif
+ prterror ('w', failed_consistency);
+ ++bad_header; /* remember for future error message */
+ }