aboutsummaryrefslogtreecommitdiff
path: root/archivers/zoo
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-10-18 01:04:46 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-10-18 01:04:46 +0000
commit9e3dd664b96a8c662fdf16054d35da02f6d12de9 (patch)
tree4abf595a8bf31d9a408606c02c6ea458c90a634e /archivers/zoo
parentb16aec708154c2a657fb55d4df1e3aa31e21e3e2 (diff)
downloadports-9e3dd664b96a8c662fdf16054d35da02f6d12de9.tar.gz
ports-9e3dd664b96a8c662fdf16054d35da02f6d12de9.zip
Notes
Diffstat (limited to 'archivers/zoo')
-rw-r--r--archivers/zoo/Makefile6
-rw-r--r--archivers/zoo/files/patch-aa19
-rw-r--r--archivers/zoo/pkg-comment1
-rw-r--r--archivers/zoo/pkg-descr7
-rw-r--r--archivers/zoo/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/archivers/zoo/Makefile b/archivers/zoo/Makefile
new file mode 100644
index 000000000000..2cd53b4fe296
--- /dev/null
+++ b/archivers/zoo/Makefile
@@ -0,0 +1,6 @@
+DISTFILES= zoo210.tar.Z
+DISTNAME= zoo
+MASTER_SITES= ftp://garbo.uwasa.fi/unix/arcers/
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/zoo/files/patch-aa b/archivers/zoo/files/patch-aa
new file mode 100644
index 000000000000..397e18b3a938
--- /dev/null
+++ b/archivers/zoo/files/patch-aa
@@ -0,0 +1,19 @@
+*** bsd.c~ Wed Aug 7 23:34:07 1991
+--- bsd.c Mon Oct 17 16:41:17 1994
+***************
+*** 98,104 ****
+ /* Truncate a file. */
+ int zootrunc(f) FILE *f;
+ {
+! extern long lseek();
+ long seekpos;
+ int fd = fileno(f);
+ seekpos = lseek(fd, 0L, SEEK_CUR);
+--- 98,104 ----
+ /* Truncate a file. */
+ int zootrunc(f) FILE *f;
+ {
+! extern off_t lseek();
+ long seekpos;
+ int fd = fileno(f);
+ seekpos = lseek(fd, 0L, SEEK_CUR);
diff --git a/archivers/zoo/pkg-comment b/archivers/zoo/pkg-comment
new file mode 100644
index 000000000000..48bda526dca9
--- /dev/null
+++ b/archivers/zoo/pkg-comment
@@ -0,0 +1 @@
+zoo - manipulate archives of files in compressed form. Version 2.10 \ No newline at end of file
diff --git a/archivers/zoo/pkg-descr b/archivers/zoo/pkg-descr
new file mode 100644
index 000000000000..6c9afde5eb00
--- /dev/null
+++ b/archivers/zoo/pkg-descr
@@ -0,0 +1,7 @@
+Zoo is used to create and maintain collections of files in compressed
+form. It uses a Lempel-Ziv compression algorithm that gives space
+savings in the range of 20% to 80% depending on the type of file
+data. Zoo can store and selectively extract multiple generations of
+the same file. Data can be recovered from damaged archives by
+skipping the damaged portion and locating undamaged data with the help
+of fiz(1).
diff --git a/archivers/zoo/pkg-plist b/archivers/zoo/pkg-plist
new file mode 100644
index 000000000000..8fa75af42081
--- /dev/null
+++ b/archivers/zoo/pkg-plist
@@ -0,0 +1,8 @@
+@cd /usr/local
+@owner bin
+@mode 755
+bin/fiz
+bin/zoo
+@mode 644
+man/man1/fiz.1
+man/man1/zoo.1