aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-09-19 17:31:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-09-19 17:31:04 +0000
commit1aa242f0832ab97cc439b7a485d3643cafeca356 (patch)
tree2f358369ac6f5b8df35cd3ab8d5f50e3854ea869 /archivers
parentebc2572df241e766503b3d01290035b51bde0b69 (diff)
downloadports-1aa242f0832ab97cc439b7a485d3643cafeca356.tar.gz
ports-1aa242f0832ab97cc439b7a485d3643cafeca356.zip
- Openssl and nettle support are not mutually exclusive, add independent options for each
- Add LICENSE_FILE - Switch to USES=localbase - Switch to new test framework PR: 231150 Approved by: maintainer timeout (glewis, 2 weeks)
Notes
Notes: svn path=/head/; revision=480098
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libarchive/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 965bec45e113..6254c0c9ae73 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libarchive
PORTVERSION= 3.3.2
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://libarchive.org/downloads/
@@ -10,20 +11,23 @@ MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
-OPTIONS_DEFINE= LZ4 LZO NETTLE
-OPTIONS_DEFAULT=LZ4 LZO
+OPTIONS_DEFINE= LZ4 LZO OPENSSL NETTLE
+OPTIONS_DEFAULT=LZ4 LZO OPENSSL
LZ4_DESC= Support lz4 compression via liblz4
LZO_DESC= Support lzo compression via liblzo2
-NETTLE_DESC= Use Nettle instead of OpenSSL
+OPENSSL_DESC= Mtree and xar hashes support through openssl
+NETTLE_DESC= Crypto support from Nettle
-USES= cpe iconv libtool pathfix
+USES= cpe iconv libtool localbase:ldflags pathfix
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+TEST_TARGET= check
CONFIGURE_ARGS= --without-xml2
@@ -81,10 +85,6 @@ PLIST_FILES= bin/bsdcat \
man/man5/mtree.5.gz \
man/man5/tar.5.gz
-CFLAGS+= "-I${LOCALBASE}/include"
-CPPFLAGS+= "-I${LOCALBASE}/include"
-LDFLAGS+= "-L${LOCALBASE}/lib"
-
LZO_LIB_DEPENDS= liblzo2.so:archivers/lzo2
LZO_CONFIGURE_WITH= lzo2
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
@@ -92,9 +92,8 @@ LZ4_CONFIGURE_WITH= lz4
NETTLE_LIB_DEPENDS= libnettle.so:security/nettle
NETTLE_CONFIGURE_WITH= nettle
-NETTLE_CONFIGURE_ON= --without-openssl
-NETTLE_USES_OFF= ssl
-NETTLE_CONFIGURE_OFF= --with-openssl
+OPENSSL_USES= ssl
+OPENSSL_CONFIGURE_WITH= openssl
.include <bsd.port.pre.mk>
@@ -104,7 +103,4 @@ CONFIGURE_ENV+= ac_cv_header_localcharset_h=no \
ac_cv_lib_charset_locale_charset=no
.endif
-check:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check)
-
.include <bsd.port.post.mk>