aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2018-10-07 16:33:21 +0000
committerGreg Lewis <glewis@FreeBSD.org>2018-10-07 16:33:21 +0000
commit1dd5897b9dd2fcd586b2478359898083a736326a (patch)
tree9b5683ba74b480e504c3ab2c282fc451197b6d00 /archivers
parentbd2a1acde643e52cead62b7bf2e628d23d602dd5 (diff)
downloadports-1dd5897b9dd2fcd586b2478359898083a736326a.tar.gz
ports-1dd5897b9dd2fcd586b2478359898083a736326a.zip
. Update to 3.3.3
. Add support for zstd compression
Notes
Notes: svn path=/head/; revision=481459
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libarchive/Makefile8
-rw-r--r--archivers/libarchive/distinfo6
-rw-r--r--archivers/libarchive/files/patch-libarchive_openssl_hmac_private.h12
3 files changed, 8 insertions, 18 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 6254c0c9ae73..b4c9deaed492 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 3.3.2
+PORTVERSION= 3.3.3
PORTEPOCH= 1
-PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://libarchive.org/downloads/
@@ -15,13 +14,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
-OPTIONS_DEFINE= LZ4 LZO OPENSSL NETTLE
+OPTIONS_DEFINE= LZ4 LZO OPENSSL NETTLE ZSTD
OPTIONS_DEFAULT=LZ4 LZO OPENSSL
LZ4_DESC= Support lz4 compression via liblz4
LZO_DESC= Support lzo compression via liblzo2
OPENSSL_DESC= Mtree and xar hashes support through openssl
NETTLE_DESC= Crypto support from Nettle
+ZSTD_DESC= Support zstd compression
USES= cpe iconv libtool localbase:ldflags pathfix
GNU_CONFIGURE= yes
@@ -89,6 +89,8 @@ LZO_LIB_DEPENDS= liblzo2.so:archivers/lzo2
LZO_CONFIGURE_WITH= lzo2
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
LZ4_CONFIGURE_WITH= lz4
+ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
+ZSTD_CONFIGURE_WITH= zstd
NETTLE_LIB_DEPENDS= libnettle.so:security/nettle
NETTLE_CONFIGURE_WITH= nettle
diff --git a/archivers/libarchive/distinfo b/archivers/libarchive/distinfo
index 1934c6af9021..121098215628 100644
--- a/archivers/libarchive/distinfo
+++ b/archivers/libarchive/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1509320100
-SHA256 (libarchive-3.3.2.tar.gz) = ed2dbd6954792b2c054ccf8ec4b330a54b85904a80cef477a1c74643ddafa0ce
-SIZE (libarchive-3.3.2.tar.gz) = 6236562
+TIMESTAMP = 1538928569
+SHA256 (libarchive-3.3.3.tar.gz) = ba7eb1781c9fbbae178c4c6bad1c6eb08edab9a1496c64833d1715d022b30e2e
+SIZE (libarchive-3.3.3.tar.gz) = 6535598
diff --git a/archivers/libarchive/files/patch-libarchive_openssl_hmac_private.h b/archivers/libarchive/files/patch-libarchive_openssl_hmac_private.h
deleted file mode 100644
index fe138bb3aa40..000000000000
--- a/archivers/libarchive/files/patch-libarchive_openssl_hmac_private.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- libarchive/archive_openssl_hmac_private.h.orig 2018-03-22 20:47:12 UTC
-+++ libarchive/archive_openssl_hmac_private.h
-@@ -28,7 +28,8 @@
- #include <openssl/hmac.h>
- #include <openssl/opensslv.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
-+ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL)
- #include <stdlib.h> /* malloc, free */
- #include <string.h> /* memset */
- static inline HMAC_CTX *HMAC_CTX_new(void)