aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
commit42542fb07642b8336e808272918f3ae46aa67e0b (patch)
tree98ff235c33c6493aa26457284f122652c38935f7 /archivers
parent4c9cd257fd4e6eca46807a43e128d298429ee3cd (diff)
downloadports-42542fb07642b8336e808272918f3ae46aa67e0b.tar.gz
ports-42542fb07642b8336e808272918f3ae46aa67e0b.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/9e/Makefile2
-rw-r--r--archivers/bzip/Makefile6
-rw-r--r--archivers/dact/Makefile6
-rw-r--r--archivers/dpkg/Makefile2
-rw-r--r--archivers/ecm/Makefile2
-rw-r--r--archivers/gzrecover/Makefile2
-rw-r--r--archivers/mar/Makefile2
-rw-r--r--archivers/mscompress/Makefile4
-rw-r--r--archivers/mtf/Makefile2
-rw-r--r--archivers/unace/Makefile2
-rw-r--r--archivers/unalz/Makefile2
-rw-r--r--archivers/undms/Makefile2
-rw-r--r--archivers/unlzx/Makefile2
-rw-r--r--archivers/unmakeself/Makefile2
-rw-r--r--archivers/untar/Makefile2
-rw-r--r--archivers/unzoo/Makefile2
16 files changed, 21 insertions, 21 deletions
diff --git a/archivers/9e/Makefile b/archivers/9e/Makefile
index a51a6ec839ba..ea81cddae274 100644
--- a/archivers/9e/Makefile
+++ b/archivers/9e/Makefile
@@ -18,6 +18,6 @@ PLIST_FILES= bin/9e
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LIBS="" HDRS=""
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/9e ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/9e ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/bzip/Makefile b/archivers/bzip/Makefile
index 7d252fea13d2..116fd7bd7325 100644
--- a/archivers/bzip/Makefile
+++ b/archivers/bzip/Makefile
@@ -24,9 +24,9 @@ pre-install:
@${CAT} ${FILESDIR}/COPYRIGHT
do-install:
- ${RM} -f ${PREFIX}/bin/bzip ${TARGETDIR}/bin/bunzip
- ${INSTALL_PROGRAM} ${WRKSRC}/bzip ${TARGETDIR}/bin/bzip
- ${LN} -fs ${TARGETDIR}/bin/bzip ${TARGETDIR}/bin/bunzip
+ ${RM} -f ${PREFIX}/bin/bzip ${PREFIX}/bin/bunzip
+ ${INSTALL_PROGRAM} ${WRKSRC}/bzip ${PREFIX}/bin/bzip
+ ${LN} -fs ${PREFIX}/bin/bzip ${PREFIX}/bin/bunzip
${INSTALL_MAN} ${WRKSRC}/bzip.1 ${MAN1PREFIX}/man/man1/bzip.1
${INSTALL_MAN} ${WRKSRC}/bzip.1 ${MAN1PREFIX}/man/man1/bunzip.1
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index 96cad62206f0..9f7fe10d4573 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -31,8 +31,8 @@ MAN1= dact.1
INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e "s|prefix = @prefix@|prefix = ${TARGETDIR}|" \
- -e "s|libdir = @libdir@|libdir = ${TARGETDIR}/lib|" \
+ @${REINPLACE_CMD} -e "s|prefix = @prefix@|prefix = ${PREFIX}|" \
+ -e "s|libdir = @libdir@|libdir = ${PREFIX}/lib|" \
${WRKSRC}/Makefile.in
pre-install:
@@ -40,7 +40,7 @@ pre-install:
@${RM} -f ${WRKSRC}/libdact.a
post-install:
- @${CP} -n ${EXAMPLESDIR}/dact.conf ${TARGETDIR}/etc
+ @${CP} -n ${EXAMPLESDIR}/dact.conf ${PREFIX}/etc
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Docs/dact.txt ${DOCSDIR}
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index b254469203fd..150e2786156e 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -24,7 +24,7 @@ USE_ICONV= yes
USE_PERL5= yes
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
-DPKGDIR?= ${DESTDIR}/var/db/dpkg
+DPKGDIR?= /var/db/dpkg
PLIST_SUB+= DPKGDIR=${DPKGDIR:C,^/,,}
SUB_FILES= pkg-install pkg-deinstall
diff --git a/archivers/ecm/Makefile b/archivers/ecm/Makefile
index bb440f9fb217..6302a84af232 100644
--- a/archivers/ecm/Makefile
+++ b/archivers/ecm/Makefile
@@ -19,7 +19,7 @@ PORTDOCS= format.txt
do-install:
.for f in ${PORTNAME} un${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.if !defined(NOPORTDOCS)
diff --git a/archivers/gzrecover/Makefile b/archivers/gzrecover/Makefile
index c94ce75763a0..6680a519627a 100644
--- a/archivers/gzrecover/Makefile
+++ b/archivers/gzrecover/Makefile
@@ -25,7 +25,7 @@ do-build:
${CC} -o ${WRKSRC}/${PORTNAME} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/archivers/mar/Makefile b/archivers/mar/Makefile
index 46599a325da1..3e1199196b76 100644
--- a/archivers/mar/Makefile
+++ b/archivers/mar/Makefile
@@ -26,7 +26,7 @@ post-patch:
${WRKSRC}/src/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/mar.1 ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
diff --git a/archivers/mscompress/Makefile b/archivers/mscompress/Makefile
index 05b59dbb94d8..fe5eef38c531 100644
--- a/archivers/mscompress/Makefile
+++ b/archivers/mscompress/Makefile
@@ -22,8 +22,8 @@ MAN1= mscompress.1 msexpand.1
PLIST_FILES= bin/mscompress bin/msexpand
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mscompress ${TARGETDIR}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/msexpand ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mscompress ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/msexpand ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/mscompress.1 ${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/msexpand.1 ${MAN1PREFIX}/man/man1
diff --git a/archivers/mtf/Makefile b/archivers/mtf/Makefile
index f3dc865762cc..bb785b9ea7d0 100644
--- a/archivers/mtf/Makefile
+++ b/archivers/mtf/Makefile
@@ -26,7 +26,7 @@ post-patch:
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mtf ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mtf ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/archivers/unace/Makefile b/archivers/unace/Makefile
index c73bef4d2936..27f60e54fef0 100644
--- a/archivers/unace/Makefile
+++ b/archivers/unace/Makefile
@@ -29,6 +29,6 @@ post-patch:
${WRKSRC}/uac_crt.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unace ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unace ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/unalz/Makefile b/archivers/unalz/Makefile
index 35b80e385235..29473f7b1708 100644
--- a/archivers/unalz/Makefile
+++ b/archivers/unalz/Makefile
@@ -31,6 +31,6 @@ pre-patch:
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unalz ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unalz ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/undms/Makefile b/archivers/undms/Makefile
index 1c9759d04222..6d1bded84e72 100644
--- a/archivers/undms/Makefile
+++ b/archivers/undms/Makefile
@@ -27,6 +27,6 @@ do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -o undms undms-1.3.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/undms ${TARGETDIR}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/undms ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/archivers/unlzx/Makefile b/archivers/unlzx/Makefile
index 028e36aa8c02..2cfdd418d46a 100644
--- a/archivers/unlzx/Makefile
+++ b/archivers/unlzx/Makefile
@@ -26,6 +26,6 @@ do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/unmakeself/Makefile b/archivers/unmakeself/Makefile
index e7d6b837c2e8..f596039587a7 100644
--- a/archivers/unmakeself/Makefile
+++ b/archivers/unmakeself/Makefile
@@ -40,6 +40,6 @@ do-build:
${FILESDIR}/unmakeself.c ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unmakeself ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unmakeself ${PREFIX}/bin
.include <bsd.port.post.mk>
diff --git a/archivers/untar/Makefile b/archivers/untar/Makefile
index 09f6a473e54e..4050a3d3a6fd 100644
--- a/archivers/untar/Makefile
+++ b/archivers/untar/Makefile
@@ -29,6 +29,6 @@ pre-patch:
@${CP} ${DISTDIR}/untar.c ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/unzoo/Makefile b/archivers/unzoo/Makefile
index 8a2de1846d69..3024fbb94805 100644
--- a/archivers/unzoo/Makefile
+++ b/archivers/unzoo/Makefile
@@ -39,7 +39,7 @@ do-build:
${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/debian/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.post.mk>