aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-04 14:05:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-04 14:05:27 +0000
commitf0d36411c6d8cdbf0ac872ecf35a13c3e61f80e0 (patch)
treedb4d24952bf0cae218bdf790653cbe865ea72ba8 /archivers
parent05578e351a1721b733ecf626af74f4fe09cff3fa (diff)
downloadports-f0d36411c6d8cdbf0ac872ecf35a13c3e61f80e0.tar.gz
ports-f0d36411c6d8cdbf0ac872ecf35a13c3e61f80e0.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/torrentzip/Makefile39
-rw-r--r--archivers/torrentzip/distinfo2
-rw-r--r--archivers/torrentzip/pkg-descr8
4 files changed, 50 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 927f27a00ff7..d5bc7a7ce121 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -84,6 +84,7 @@
SUBDIR += stuffit
SUBDIR += szip
SUBDIR += tardy
+ SUBDIR += torrentzip
SUBDIR += ucl
SUBDIR += unace
SUBDIR += unadf
diff --git a/archivers/torrentzip/Makefile b/archivers/torrentzip/Makefile
new file mode 100644
index 000000000000..6587174a4d8f
--- /dev/null
+++ b/archivers/torrentzip/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: torrentzip
+# Date created: May 2, 2005
+# Whom: swhetzel@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= torrentzip
+PORTVERSION= 0.2
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= trrntzip
+DISTNAME= trrntzip_v${PORTVERSION:S/.//}_src
+
+MAINTAINER= swhetzel@gmail.com
+COMMENT= Efficient way to prepare zipfiles for BitTorrent
+
+USE_AUTOMAKE_VER= 19
+AUTOMAKE_ARGS= -a
+USE_AUTOHEADER_VER= 259
+
+WRKSRC= ${WRKDIR}/trrntzip
+
+PLIST_FILES= bin/trrntzip
+PORTDOCS= README
+
+run-autotools:
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} ${ACLOCAL_ARGS})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} ${AUTOHEADER_ARGS})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} ${AUTOCONF_ARGS})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} ${AUTOMAKE_ARGS})
+
+.if !defined(NOPORTDOCS)
+pre-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>
diff --git a/archivers/torrentzip/distinfo b/archivers/torrentzip/distinfo
new file mode 100644
index 000000000000..7d63660c8c2e
--- /dev/null
+++ b/archivers/torrentzip/distinfo
@@ -0,0 +1,2 @@
+MD5 (trrntzip_v02_src.tar.gz) = 2635a4042b3cf5611ffdffb4019ec8b7
+SIZE (trrntzip_v02_src.tar.gz) = 46971
diff --git a/archivers/torrentzip/pkg-descr b/archivers/torrentzip/pkg-descr
new file mode 100644
index 000000000000..3bf8f12fcaab
--- /dev/null
+++ b/archivers/torrentzip/pkg-descr
@@ -0,0 +1,8 @@
+TorrentZip creates byte-for-byte exact zip files on any machine. This allows
+people to join a torrent (after they have converted their zip files) with a
+particular set of files, thus preventing them from having to download the
+entire set of files again. Because of the way TorrentZip creates identical
+zips, the file hashes will always match those in the original torrent.
+
+WWW: http://trrntzip.sourceforge.net
+ https://sourceforge.net/projects/trrntzip