aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-09-02 14:30:26 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-09-02 14:30:26 +0000
commitf6addc7044982699cdc54163e79926090f28ddb5 (patch)
treefb0fa3eb730b55d7252c5942c6d1e640b19761f2 /archivers
parentfb98da9bd009298f740a63d481dd34b6ca4cb0c1 (diff)
downloadports-f6addc7044982699cdc54163e79926090f28ddb5.tar.gz
ports-f6addc7044982699cdc54163e79926090f28ddb5.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/zutils/Makefile5
-rw-r--r--archivers/zutils/distinfo4
-rw-r--r--archivers/zutils/files/patch-zupdate.cc10
-rw-r--r--archivers/zutils/files/patch-zutils.h12
4 files changed, 5 insertions, 26 deletions
diff --git a/archivers/zutils/Makefile b/archivers/zutils/Makefile
index e213be0f869f..81c86c90bcee 100644
--- a/archivers/zutils/Makefile
+++ b/archivers/zutils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zutils
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= archivers
MASTER_SITES= SAVANNAH/zutils
EXTRACT_SUFX= .tar.lz
@@ -17,6 +17,7 @@ EXTRACT_DEPENDS= lzip:${PORTSDIR}/archivers/lzip
INFO= zutils
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
do-extract:
@${MKDIR} ${WRKDIR}
@@ -25,7 +26,7 @@ do-extract:
post-patch:
# Remove compiler hardcoded flags and use environment
- @${REINPLACE_CMD} '24,27d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '23,26d' ${WRKSRC}/configure
post-install:
@-${RM} ${STAGEDIR}${PREFIX}/info/dir
diff --git a/archivers/zutils/distinfo b/archivers/zutils/distinfo
index ba272dbac013..0bf3ee32561b 100644
--- a/archivers/zutils/distinfo
+++ b/archivers/zutils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zutils-1.2.tar.lz) = 987fc1971493cde29b046f9d1392a74c81df201bf9d416e350e073273c4b358e
-SIZE (zutils-1.2.tar.lz) = 46544
+SHA256 (zutils-1.3.tar.lz) = 17b8d5093e8c7284c506157cadec1152246043e470cb87311b787932c60973f1
+SIZE (zutils-1.3.tar.lz) = 40838
diff --git a/archivers/zutils/files/patch-zupdate.cc b/archivers/zutils/files/patch-zupdate.cc
deleted file mode 100644
index 9e0a47f3eb3c..000000000000
--- a/archivers/zutils/files/patch-zupdate.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./zupdate.cc.orig 2014-02-22 09:12:36.000000000 -0300
-+++ ./zupdate.cc 2014-02-22 09:12:57.000000000 -0300
-@@ -32,6 +32,7 @@
- #include <unistd.h>
- #include <utime.h>
- #include <sys/stat.h>
-+#include <sys/wait.h>
- #if defined(__MSVCRT__) || defined(__OS2__)
- #include <io.h>
- #endif
diff --git a/archivers/zutils/files/patch-zutils.h b/archivers/zutils/files/patch-zutils.h
deleted file mode 100644
index 95e8928411ee..000000000000
--- a/archivers/zutils/files/patch-zutils.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./zutils.h.orig 2014-01-30 14:46:32.000000000 -0200
-+++ ./zutils.h 2014-02-22 09:12:24.000000000 -0300
-@@ -15,6 +15,9 @@
- along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-+#include <sys/types.h>
-+#include <signal.h>
-+
- int parse_format_type( const std::string & arg );
-
- int readblock( const int fd, uint8_t * const buf, const int size );