aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-17 15:54:22 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-17 15:54:22 +0000
commitc2fb6a937fd65183481607db146b3a72dbd647a8 (patch)
treea9ea93071c749db674cde50563b2a3cfa15657dc /archivers
parent7449bc83ce1916cde043a8be259a234679e1c4d9 (diff)
downloadports-c2fb6a937fd65183481607db146b3a72dbd647a8.tar.gz
ports-c2fb6a937fd65183481607db146b3a72dbd647a8.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/quazip/Makefile3
-rw-r--r--archivers/quazip/distinfo4
-rw-r--r--archivers/quazip/files/patch-qztest__testquagzipfile.cpp30
3 files changed, 3 insertions, 34 deletions
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index 0ac984cda8ca..aa2ba516f70d 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quazip
-PORTVERSION= 0.5.1
-#PORTREVISION= 0
+PORTVERSION= 0.6.2
CATEGORIES= archivers
MASTER_SITES= SF
diff --git a/archivers/quazip/distinfo b/archivers/quazip/distinfo
index 953c2f732ab7..dacd1f1e59eb 100644
--- a/archivers/quazip/distinfo
+++ b/archivers/quazip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quazip-0.5.1.tar.gz) = 078176a72288983f78b45c15f7d245131d9d5fc36a22f2757d75a78658c33268
-SIZE (quazip-0.5.1.tar.gz) = 354658
+SHA256 (quazip-0.6.2.tar.gz) = adf4047213662a0362090edaaee4283216df2034ab5923697f9aa81d081c0b43
+SIZE (quazip-0.6.2.tar.gz) = 423027
diff --git a/archivers/quazip/files/patch-qztest__testquagzipfile.cpp b/archivers/quazip/files/patch-qztest__testquagzipfile.cpp
deleted file mode 100644
index 52f103078049..000000000000
--- a/archivers/quazip/files/patch-qztest__testquagzipfile.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- qztest/testquagzipfile.cpp.orig 2012-09-05 15:24:35.000000000 +0000
-+++ qztest/testquagzipfile.cpp
-@@ -8,9 +8,9 @@ void TestQuaGzipFile::read()
- {
- QDir curDir;
- curDir.mkpath("tmp");
-- voidp gzFile = gzopen("tmp/test.gz", "wb");
-- gzwrite(gzFile, "test", 4);
-- gzclose(gzFile);
-+ gzFile gzf = gzopen("tmp/test.gz", "wb");
-+ gzwrite(gzf, "test", 4);
-+ gzclose(gzf);
- QuaGzipFile testFile("tmp/test.gz");
- QVERIFY(testFile.open(QIODevice::ReadOnly));
- char buf[5];
-@@ -32,11 +32,11 @@ void TestQuaGzipFile::write()
- QCOMPARE(testFile.write("test", 4), static_cast<qint64>(4));
- testFile.close();
- QVERIFY(!testFile.isOpen());
-- voidp gzFile = gzopen("tmp/test.gz", "rb");
-+ gzFile gzf = gzopen("tmp/test.gz", "rb");
- char buf[5];
- buf[4] = '\0';
-- QCOMPARE(gzread(gzFile, buf, 5), 4);
-- gzclose(gzFile);
-+ QCOMPARE(gzread(gzf, buf, 5), 4);
-+ gzclose(gzf);
- QCOMPARE(static_cast<const char*>(buf), "test");
- curDir.remove("tmp/test.gz");
- curDir.rmdir("tmp");