aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-10 14:10:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-10 14:10:04 +0000
commit295abdbc9408048ee74ec3d0b1cfac95687e292d (patch)
tree8fd09aecf617c8b448883cb8b31d516068a01488 /archivers
parent5703f1002380fb5ef2ca6716ef3e35629a0323fe (diff)
downloadports-295abdbc9408048ee74ec3d0b1cfac95687e292d.tar.gz
ports-295abdbc9408048ee74ec3d0b1cfac95687e292d.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/xarchive/Makefile61
-rw-r--r--archivers/xarchive/distinfo3
-rw-r--r--archivers/xarchive/pkg-descr12
-rw-r--r--archivers/xarchive/pkg-plist16
5 files changed, 93 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index ff4ba0c376a7..ca430b46ea7d 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -110,6 +110,7 @@
SUBDIR += unzoo
SUBDIR += upx
SUBDIR += wzip
+ SUBDIR += xarchive
SUBDIR += xdms
SUBDIR += xmill
SUBDIR += xpk
diff --git a/archivers/xarchive/Makefile b/archivers/xarchive/Makefile
new file mode 100644
index 000000000000..f2db8e69f9c9
--- /dev/null
+++ b/archivers/xarchive/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: xarchive
+# Date created: 09 November 2005
+# Whom: Mark Kane <mark@mkproductions.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xarchive
+PORTVERSION= 0.2.6.3
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0.2.6-3
+
+MAINTAINER= mark@mkproductions.org
+COMMENT= A GTK+ front end for archiving tools
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+MAN1= xarchive.1
+
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+
+OPTIONS= 7ZIP "Support for 7zip archives" off \
+ ARJ "Support for ARJ archives" off \
+ ACE "Support for ACE archives" off \
+ RAR "Support for RAR archives" off \
+ RPM "Support for RPM archives" off \
+ ZIP "Support for ZIP archives" off
+
+.include <bsd.port.pre.mk>
+
+.if defined (WITH_7ZIP)
+RUN_DEPENDS+= 7z:${PORTSDIR}/archivers/p7zip
+.endif
+
+.if defined (WITH_ARJ)
+RUN_DEPENDS+= arj:${PORTSDIR}/archivers/arj
+.endif
+
+.if defined (WITH_ACE)
+RUN_DEPENDS+= unace:${PORTSDIR}/archivers/unace
+.endif
+
+.if defined (WITH_RAR)
+RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar \
+ unrar:${PORTSDIR}/archivers/unrar
+.endif
+
+.if defined (WITH_RPM)
+RUN_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm4
+.endif
+
+.if defined (WITH_ZIP)
+RUN_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
+ unzip:${PORTSDIR}/archivers/unzip
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/xarchive/distinfo b/archivers/xarchive/distinfo
new file mode 100644
index 000000000000..b731e50fe478
--- /dev/null
+++ b/archivers/xarchive/distinfo
@@ -0,0 +1,3 @@
+MD5 (xarchive-0.2.6-3.tar.gz) = 5122f3662020ac54560f8a530a64a1f6
+SHA256 (xarchive-0.2.6-3.tar.gz) = 7f9da2b021188831d5d4cef71f5af3a66d9d5ecf071c7a039e3cc375b98c89e6
+SIZE (xarchive-0.2.6-3.tar.gz) = 150530
diff --git a/archivers/xarchive/pkg-descr b/archivers/xarchive/pkg-descr
new file mode 100644
index 000000000000..9814c19aa536
--- /dev/null
+++ b/archivers/xarchive/pkg-descr
@@ -0,0 +1,12 @@
+XArchive is a GTK+ front end for command line archiving tools such as tar, rar,
+zip, ace, 7zip, arj, and rpm.
+
+It uses external bash shell wrappers to handle the different types of file
+formats, so adding support for new archive types can be easily done by writing
+a wrapper.
+
+WWW: http://xarchive.sourceforge.net
+
+- Mark
+mark@mkproductions.org
+http://www.mkproductions.org
diff --git a/archivers/xarchive/pkg-plist b/archivers/xarchive/pkg-plist
new file mode 100644
index 000000000000..1eab96bfcb8b
--- /dev/null
+++ b/archivers/xarchive/pkg-plist
@@ -0,0 +1,16 @@
+bin/xarchive
+lib/xarchive/wrappers/7za-wrap.sh
+lib/xarchive/wrappers/arj-wrap.sh
+lib/xarchive/wrappers/deb-wrap.sh
+lib/xarchive/wrappers/rar-wrap.sh
+lib/xarchive/wrappers/rpm-wrap.sh
+lib/xarchive/wrappers/tar-wrap.sh
+lib/xarchive/wrappers/zip-wrap.sh
+share/applications/xarchive.desktop
+share/doc/xarchive/xarchive.1.html
+share/doc/xarchive/xarchive.1.txt
+share/pixmaps/xarchive.xpm
+@dirrm share/doc/xarchive
+@unexec rmdir %D/share/applications 2>/dev/null || true
+@dirrm lib/xarchive/wrappers
+@dirrm lib/xarchive