aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-08-28 15:40:54 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-08-28 15:40:54 +0000
commit1469649b382ac727244d44aefe7f50fcd929a9b8 (patch)
tree90c9f688b26b7819470188e1ed36a0214fafb668 /archivers
parente751af5859e1ade93237f62a4dc43ee3c399d75b (diff)
downloadports-1469649b382ac727244d44aefe7f50fcd929a9b8.tar.gz
ports-1469649b382ac727244d44aefe7f50fcd929a9b8.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/quazip/Makefile2
-rw-r--r--archivers/quazip/files/patch-qztest__testquagzipfile.cpp28
2 files changed, 19 insertions, 11 deletions
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index a6afaac30626..704ae7be4fd1 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -12,8 +12,6 @@ COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
LICENSE= LGPL21
-BROKEN= Does not build
-
QMAKE_ARGS= PREFIX=${PREFIX} ${QMAKE_PRO}
QMAKE_PRO= ${WRKSRC}/${PORTNAME}.pro
diff --git a/archivers/quazip/files/patch-qztest__testquagzipfile.cpp b/archivers/quazip/files/patch-qztest__testquagzipfile.cpp
index 8e58f5e6f2e7..52f103078049 100644
--- a/archivers/quazip/files/patch-qztest__testquagzipfile.cpp
+++ b/archivers/quazip/files/patch-qztest__testquagzipfile.cpp
@@ -1,20 +1,30 @@
---- ./qztest/testquagzipfile.cpp.orig 2013-06-15 14:53:18.000000000 +0200
-+++ ./qztest/testquagzipfile.cpp 2013-06-15 14:51:57.000000000 +0200
-@@ -8,7 +8,7 @@
+--- qztest/testquagzipfile.cpp.orig 2012-09-05 15:24:35.000000000 +0000
++++ qztest/testquagzipfile.cpp
+@@ -8,9 +8,9 @@ void TestQuaGzipFile::read()
{
QDir curDir;
curDir.mkpath("tmp");
- voidp gzFile = gzopen("tmp/test.gz", "wb");
-+ gzFile_s* /*voidp*/ gzFile = gzopen("tmp/test.gz", "wb");
- gzwrite(gzFile, "test", 4);
- gzclose(gzFile);
+- gzwrite(gzFile, "test", 4);
+- gzclose(gzFile);
++ gzFile gzf = gzopen("tmp/test.gz", "wb");
++ gzwrite(gzf, "test", 4);
++ gzclose(gzf);
QuaGzipFile testFile("tmp/test.gz");
-@@ -32,7 +32,7 @@
+ QVERIFY(testFile.open(QIODevice::ReadOnly));
+ char buf[5];
+@@ -32,11 +32,11 @@ void TestQuaGzipFile::write()
QCOMPARE(testFile.write("test", 4), static_cast<qint64>(4));
testFile.close();
QVERIFY(!testFile.isOpen());
- voidp gzFile = gzopen("tmp/test.gz", "rb");
-+ gzFile_s* /*voidp*/ gzFile = gzopen("tmp/test.gz", "rb");
++ gzFile gzf = gzopen("tmp/test.gz", "rb");
char buf[5];
buf[4] = '\0';
- QCOMPARE(gzread(gzFile, buf, 5), 4);
+- QCOMPARE(gzread(gzFile, buf, 5), 4);
+- gzclose(gzFile);
++ QCOMPARE(gzread(gzf, buf, 5), 4);
++ gzclose(gzf);
+ QCOMPARE(static_cast<const char*>(buf), "test");
+ curDir.remove("tmp/test.gz");
+ curDir.rmdir("tmp");