aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-06-13 15:15:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-06-13 15:15:46 +0000
commit25701d425a4298969c10ee9ac3f8a21d6a13984c (patch)
treec127b9717d63b06d2c2ed55092347640d428dc81 /archivers
parente094d9cc56b27fd27ab7f265261b0b3bbf950663 (diff)
downloadports-25701d425a4298969c10ee9ac3f8a21d6a13984c.tar.gz
ports-25701d425a4298969c10ee9ac3f8a21d6a13984c.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lziprecover/Makefile29
-rw-r--r--archivers/lziprecover/distinfo3
-rw-r--r--archivers/lziprecover/pkg-descr13
4 files changed, 46 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 2c2726d8239b..a05e0ee62f66 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -76,6 +76,7 @@
SUBDIR += lua51-zlib
SUBDIR += lzfse
SUBDIR += lzip
+ SUBDIR += lziprecover
SUBDIR += lzlib
SUBDIR += lzma
SUBDIR += lzmalib
diff --git a/archivers/lziprecover/Makefile b/archivers/lziprecover/Makefile
new file mode 100644
index 000000000000..b1a42ae29eb8
--- /dev/null
+++ b/archivers/lziprecover/Makefile
@@ -0,0 +1,29 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lziprecover
+PORTVERSION= 1.21
+CATEGORIES= archivers
+MASTER_SITES= SAVANNAH/lzip/${PORTNAME}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Recovery tool for Lzip compressed data files
+
+LICENSE= GPLv2+
+
+USES= tar:lz
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --infodir=${PREFIX}/${INFO_PATH} \
+ --mandir=${MANPREFIX}/man CXXFLAGS="${CXXFLAGS}"
+
+INFO= ${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/archivers/lziprecover/distinfo b/archivers/lziprecover/distinfo
new file mode 100644
index 000000000000..28c5efedbc28
--- /dev/null
+++ b/archivers/lziprecover/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546615331
+SHA256 (lziprecover-1.21.tar.lz) = 1622440336614bee73542de0461d99141ea1b1bf012fc07bd50d94e434aa34df
+SIZE (lziprecover-1.21.tar.lz) = 78509
diff --git a/archivers/lziprecover/pkg-descr b/archivers/lziprecover/pkg-descr
new file mode 100644
index 000000000000..16c61600b94a
--- /dev/null
+++ b/archivers/lziprecover/pkg-descr
@@ -0,0 +1,13 @@
+Lziprecover is a data recovery tool and decompressor for files in the
+Lzip compressed data format (.lz). Lziprecover is able to repair slightly
+damaged files, produce a correct file by merging the good parts of two or
+more damaged copies, extract data from damaged files, and test integrity
+of files.
+
+Lziprecover can remove the damaged members from multimember files, for
+example multimember .tar.lz archives.
+
+Lziprecover provides random access to the data in multimember files; it
+only decompresses the members containing the desired data.
+
+WWW: http://www.nongnu.org/lzip/lziprecover.html