aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-10 20:23:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-10 20:23:51 +0000
commitb8cc0650ddce982465a049a33f37e0c6fb7f79fc (patch)
treedb396ae0dde5422e8f9c4de6b1c81e2b747d8ebf /archivers
parent4c2ed02d35d84a48eb70ec602364cdcf3f65fc88 (diff)
downloadports-b8cc0650ddce982465a049a33f37e0c6fb7f79fc.tar.gz
ports-b8cc0650ddce982465a049a33f37e0c6fb7f79fc.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/atool/Makefile1
-rw-r--r--archivers/makeself/Makefile1
-rw-r--r--archivers/p5-Archive-Any-Plugin-Rar/Makefile1
-rw-r--r--archivers/p5-Archive-Any/Makefile1
-rw-r--r--archivers/p5-Archive-Peek/Makefile1
-rw-r--r--archivers/p5-Archive-Rar/Makefile1
-rw-r--r--archivers/p5-Archive-Tar/Makefile1
-rw-r--r--archivers/p5-Compress-LZW/Makefile1
-rw-r--r--archivers/p5-POE-Filter-Bzip2/Makefile1
-rw-r--r--archivers/pear-File_Archive/Makefile3
-rw-r--r--archivers/rox-archive/Makefile1
-rw-r--r--archivers/rpm2cpio/Makefile1
-rw-r--r--archivers/unfoo/Makefile1
13 files changed, 14 insertions, 1 deletions
diff --git a/archivers/atool/Makefile b/archivers/atool/Makefile
index 8a3c34c82f86..2d51be1e5e92 100644
--- a/archivers/atool/Makefile
+++ b/archivers/atool/Makefile
@@ -14,5 +14,6 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
USES= gmake perl5
USE_PERL5= build run
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/archivers/makeself/Makefile b/archivers/makeself/Makefile
index c439416bb476..16a48b805486 100644
--- a/archivers/makeself/Makefile
+++ b/archivers/makeself/Makefile
@@ -17,6 +17,7 @@ EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= --nox11 --target ${WRKSRC}
NO_BUILD= yes
+NO_ARCH= yes
PLIST_FILES= bin/makeself bin/makeself-header \
bin/makeself-header.sh bin/makeself.sh
diff --git a/archivers/p5-Archive-Any-Plugin-Rar/Makefile b/archivers/p5-Archive-Any-Plugin-Rar/Makefile
index a60b9c122d1d..5db48912d8f3 100644
--- a/archivers/p5-Archive-Any-Plugin-Rar/Makefile
+++ b/archivers/p5-Archive-Any-Plugin-Rar/Makefile
@@ -18,5 +18,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/archivers/p5-Archive-Any/Makefile b/archivers/p5-Archive-Any/Makefile
index 1816ef3c43f4..f51e8839a507 100644
--- a/archivers/p5-Archive-Any/Makefile
+++ b/archivers/p5-Archive-Any/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
diff --git a/archivers/p5-Archive-Peek/Makefile b/archivers/p5-Archive-Peek/Makefile
index 50e50b5aa203..5f84510738c3 100644
--- a/archivers/p5-Archive-Peek/Makefile
+++ b/archivers/p5-Archive-Peek/Makefile
@@ -21,6 +21,7 @@ TEST_DEPENDS= p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod
USES= perl5
USE_PERL5= configure
+NO_ARCH= yes
regression-test: build
cd ${WRKSRC}/ && ${MAKE} test
diff --git a/archivers/p5-Archive-Rar/Makefile b/archivers/p5-Archive-Rar/Makefile
index bb836f984a18..9b23e01ef934 100644
--- a/archivers/p5-Archive-Rar/Makefile
+++ b/archivers/p5-Archive-Rar/Makefile
@@ -14,6 +14,7 @@ COMMENT= Interface with the 'rar' command
BUILD_DEPENDS= rar:${PORTSDIR}/archivers/rar \
p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
diff --git a/archivers/p5-Archive-Tar/Makefile b/archivers/p5-Archive-Tar/Makefile
index 1454092a7dd1..606b706d62e4 100644
--- a/archivers/p5-Archive-Tar/Makefile
+++ b/archivers/p5-Archive-Tar/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
USES= perl5
USE_PERL5= configure
+NO_ARCH= yes
OPTIONS_DEFINE= TEXTDIFF
TEXTDIFF_DESC= Text::Diff support for ptardiff
diff --git a/archivers/p5-Compress-LZW/Makefile b/archivers/p5-Compress-LZW/Makefile
index 98defec1c935..311f5df74155 100644
--- a/archivers/p5-Compress-LZW/Makefile
+++ b/archivers/p5-Compress-LZW/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= p5-Moo>=1.001000:${PORTSDIR}/devel/p5-Moo \
p5-strictures>0:${PORTSDIR}/devel/p5-strictures
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
diff --git a/archivers/p5-POE-Filter-Bzip2/Makefile b/archivers/p5-POE-Filter-Bzip2/Makefile
index 311e0e08adc9..2f583fc47d00 100644
--- a/archivers/p5-POE-Filter-Bzip2/Makefile
+++ b/archivers/p5-POE-Filter-Bzip2/Makefile
@@ -16,6 +16,7 @@ BUILD_DEPENDS= p5-Compress-Bzip2>=2.08:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
diff --git a/archivers/pear-File_Archive/Makefile b/archivers/pear-File_Archive/Makefile
index 4c94a4eac432..92b2d3f4d05e 100644
--- a/archivers/pear-File_Archive/Makefile
+++ b/archivers/pear-File_Archive/Makefile
@@ -11,7 +11,8 @@ COMMENT= PEAR class to manipulate tar, gz, tgz, bz2, tbz, zip, ar (deb) files
BUILD_DEPENDS= ${PEARDIR}/MIME/Type.php:${PORTSDIR}/mail/pear-MIME_Type
RUN_DEPENDS= ${PEARDIR}/MIME/Type.php:${PORTSDIR}/mail/pear-MIME_Type
-USES= pear
+USES= pear
+NO_ARCH= yes
USE_PHP= bz2 pcre zlib
diff --git a/archivers/rox-archive/Makefile b/archivers/rox-archive/Makefile
index c6ea456d2b26..6ef919eaa763 100644
--- a/archivers/rox-archive/Makefile
+++ b/archivers/rox-archive/Makefile
@@ -13,6 +13,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
USES= python tar:bzip2
+NO_ARCH= yes
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
diff --git a/archivers/rpm2cpio/Makefile b/archivers/rpm2cpio/Makefile
index 297f3f3c43fc..1bf33d6d9cec 100644
--- a/archivers/rpm2cpio/Makefile
+++ b/archivers/rpm2cpio/Makefile
@@ -15,6 +15,7 @@ NO_WRKSUBDIR= yes
USES= perl5
NO_BUILD= yes
+NO_ARCH= yes
REINPLACE_ARGS=
PLIST_FILES= bin/rpm2cpio.pl
diff --git a/archivers/unfoo/Makefile b/archivers/unfoo/Makefile
index 6c33bca23033..d8a4468aa1dd 100644
--- a/archivers/unfoo/Makefile
+++ b/archivers/unfoo/Makefile
@@ -18,6 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= vitaminmoo
NO_BUILD= yes
+NO_ARCH= yes
PLIST_FILES= bin/${PORTNAME}
post-patch: