aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2010-01-02 22:11:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2010-01-02 22:11:22 +0000
commit463d6d0b9487d2d53d6d81e794c54147eea3142c (patch)
tree6321fc5edd26444fd57de8d9a763c93e57f9714b /archivers
parentd1054d1993e86bcf9344e285d46bb428b8ef9ce5 (diff)
downloadports-463d6d0b9487d2d53d6d81e794c54147eea3142c.tar.gz
ports-463d6d0b9487d2d53d6d81e794c54147eea3142c.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/file-roller/Makefile9
-rw-r--r--archivers/file-roller/files/patch-src_fr-command-zip.c39
2 files changed, 45 insertions, 3 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 3097cc1dcccd..792e26a05c4b 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -8,6 +8,7 @@
PORTNAME= file-roller
PORTVERSION= 2.28.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
@@ -18,7 +19,8 @@ COMMENT= An archive manager for zip files, tar, etc
OPTIONS= NAUTILUS "Enable Nautilus extension" on
-RUN_DEPENDS= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
+RUN_DEPENDS= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
USE_LDCONFIG= yes
USE_BZIP2= yes
@@ -47,8 +49,9 @@ CONFIGURE_ARGS+= --disable-nautilus-actions
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/src/fr-command-tar.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/fr-command-tar.c \
+ ${WRKSRC}/src/fr-command-zip.c
post-install:
@-update-desktop-database
diff --git a/archivers/file-roller/files/patch-src_fr-command-zip.c b/archivers/file-roller/files/patch-src_fr-command-zip.c
new file mode 100644
index 000000000000..ee9ec93de8c1
--- /dev/null
+++ b/archivers/file-roller/files/patch-src_fr-command-zip.c
@@ -0,0 +1,39 @@
+--- src/fr-command-zip.c.orig 2010-01-02 17:02:44.000000000 -0500
++++ src/fr-command-zip.c 2010-01-02 17:08:03.000000000 -0500
+@@ -187,7 +187,11 @@ fr_command_zip_list (FrCommand *comm)
+ {
+ fr_process_set_out_line_func (comm->process, list__process_line, comm);
+
++#ifdef __FreeBSD__
++ fr_process_begin_command (comm->process, "%%LOCALBASE%%/bin/unzip");
++#else
+ fr_process_begin_command (comm->process, "unzip");
++#endif
+ fr_process_set_begin_func (comm->process, list__begin, comm);
+ fr_process_add_arg (comm->process, "-ZTs");
+ fr_process_add_arg (comm->process, comm->filename);
+@@ -302,7 +306,11 @@ fr_command_zip_extract (FrCommand *comm
+ process_line__common,
+ comm);
+
++#ifdef __FreeBSD__
++ fr_process_begin_command (comm->process, "%%LOCALBASE%%/bin/unzip");
++#else
+ fr_process_begin_command (comm->process, "unzip");
++#endif
+
+ if (dest_dir != NULL) {
+ fr_process_add_arg (comm->process, "-d");
+@@ -334,7 +342,11 @@ fr_command_zip_extract (FrCommand *comm
+ static void
+ fr_command_zip_test (FrCommand *comm)
+ {
+- fr_process_begin_command (comm->process, "unzip");
++#ifdef __FreeBSD__
++ fr_process_begin_command (comm->process, "%%LOCALBASE%%/bin/unzip");
++#else
++ fr_process_begin_command (comm->process, "%%LOCALBASE%%/bin/unzip");
++#endif
+ fr_process_add_arg (comm->process, "-t");
+ add_password_arg (comm, comm->password);
+ fr_process_add_arg (comm->process, comm->filename);