aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-01-09 22:01:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-01-09 22:01:04 +0000
commit59f229954980d1a5d49de01b611bb7c33d77c466 (patch)
tree34d3faebb5bbe7ca80bab92601ccb03b835fa206 /archivers
parent645981457249b8eed002c12cdaaaf3f04e0d2655 (diff)
downloadports-59f229954980d1a5d49de01b611bb7c33d77c466.tar.gz
ports-59f229954980d1a5d49de01b611bb7c33d77c466.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-zstd/Makefile23
-rw-r--r--archivers/py-zstd/distinfo3
-rw-r--r--archivers/py-zstd/pkg-descr13
4 files changed, 40 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 82107340a6d4..00bd9096e699 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -190,6 +190,7 @@
SUBDIR += py-rjsmin
SUBDIR += py-warctools
SUBDIR += py-xopen
+ SUBDIR += py-zstd
SUBDIR += qpress
SUBDIR += quazip
SUBDIR += quazip-qt5
diff --git a/archivers/py-zstd/Makefile b/archivers/py-zstd/Makefile
new file mode 100644
index 000000000000..2247aa552ecf
--- /dev/null
+++ b/archivers/py-zstd/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= zstd
+DISTVERSION= 1.3.1
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python binding for Zstandard compression library
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libzstd.so:archivers/zstd
+
+USES= python localbase
+USE_PYTHON= distutils autoplist
+PYDISTUTILS_BUILDARGS= --external
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/zstd.so
+
+.include <bsd.port.mk>
diff --git a/archivers/py-zstd/distinfo b/archivers/py-zstd/distinfo
new file mode 100644
index 000000000000..30ace0749564
--- /dev/null
+++ b/archivers/py-zstd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515483481
+SHA256 (zstd-1.3.1.tar.gz) = d0350b4384c593279e8268dea28515eaac0b8618a8e88529f5b0923a0ebbb356
+SIZE (zstd-1.3.1.tar.gz) = 1192173
diff --git a/archivers/py-zstd/pkg-descr b/archivers/py-zstd/pkg-descr
new file mode 100644
index 000000000000..8726f25309f1
--- /dev/null
+++ b/archivers/py-zstd/pkg-descr
@@ -0,0 +1,13 @@
+Simple python bindings to Yann Collet's ZSTD compression library.
+
+Zstd, short for Zstandard, is a new lossless compression algorithm,
+which provides both good compression ratio and speed for standard
+compression needs. "Standard" translates into everyday situations
+which neither look for highest possible ratio (which LZMA and ZPAQ
+cover) nor extreme speeds (which LZ4 covers).
+
+Please note that this is a simple python binding to Zstandard.
+A more full-featured binding is Gregory Szorc's py-zstandard
+package.
+
+WWW: https://github.com/sergey-dryabzhinsky/python-zstd