aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-05-16 09:46:51 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-05-16 09:46:51 +0000
commit902a0675beeba6c01a038f9594a0c532079fd2f2 (patch)
treee640f9d726eb930319bafe09a6173a5b67843921 /archivers
parentc76d4dd7170ff14ee3d83458ff9f89cdbc7a5694 (diff)
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile4
-rw-r--r--archivers/php53-bz2/Makefile14
-rw-r--r--archivers/php53-phar/Makefile14
-rw-r--r--archivers/php53-phar/files/patch-config.m441
-rw-r--r--archivers/php53-phar/files/patch-phar.c11
-rw-r--r--archivers/php53-zip/Makefile14
-rw-r--r--archivers/php53-zip/files/patch-config.m410
-rw-r--r--archivers/php53-zlib/Makefile14
8 files changed, 122 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index eed9fa27f130..2fb6b063aa76 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -139,6 +139,10 @@
SUBDIR += php52-bz2
SUBDIR += php52-zip
SUBDIR += php52-zlib
+ SUBDIR += php53-bz2
+ SUBDIR += php53-phar
+ SUBDIR += php53-zip
+ SUBDIR += php53-zlib
SUBDIR += pigz
SUBDIR += plzip
SUBDIR += ppmd
diff --git a/archivers/php53-bz2/Makefile b/archivers/php53-bz2/Makefile
new file mode 100644
index 000000000000..dd8bf80e7dae
--- /dev/null
+++ b/archivers/php53-bz2/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-bz2
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -bz2
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php53-phar/Makefile b/archivers/php53-phar/Makefile
new file mode 100644
index 000000000000..ca8e7a72712a
--- /dev/null
+++ b/archivers/php53-phar/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-phar
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php53-phar/files/patch-config.m4 b/archivers/php53-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1a981bfefdc1
--- /dev/null
+++ b/archivers/php53-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2011-11-25 15:31:20.000000000 +0100
++++ config.m4 2011-11-25 15:47:45.000000000 +0100
+@@ -4,8 +4,38 @@
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php53-phar/files/patch-phar.c b/archivers/php53-phar/files/patch-phar.c
new file mode 100644
index 000000000000..231ec40a8423
--- /dev/null
+++ b/archivers/php53-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2011-11-25 15:38:44.000000000 +0100
++++ phar.c 2011-11-25 15:39:01.000000000 +0100
+@@ -3716,7 +3716,7 @@
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL
diff --git a/archivers/php53-zip/Makefile b/archivers/php53-zip/Makefile
new file mode 100644
index 000000000000..198c6aff896c
--- /dev/null
+++ b/archivers/php53-zip/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-zip
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -zip
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php53-zip/files/patch-config.m4 b/archivers/php53-zip/files/patch-config.m4
new file mode 100644
index 000000000000..a87640ff160d
--- /dev/null
+++ b/archivers/php53-zip/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig 2009-04-09 16:16:30.000000000 +0200
++++ config.m4 2009-04-09 16:17:02.000000000 +0200
+@@ -65,6 +65,7 @@
+ #endif
+ ],[
+ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
+ ],[
+ PHP_PCRE_REGEX=no
+ ])
diff --git a/archivers/php53-zlib/Makefile b/archivers/php53-zlib/Makefile
new file mode 100644
index 000000000000..0deb0e5b2aa9
--- /dev/null
+++ b/archivers/php53-zlib/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-zlib
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"