aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /archivers
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/kf5-karchive/Makefile15
-rw-r--r--archivers/kf5-karchive/distinfo3
-rw-r--r--archivers/kf5-karchive/pkg-descr7
-rw-r--r--archivers/kf5-karchive/pkg-plist34
5 files changed, 60 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 8736b14d4c7d..88de5c6f472c 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -48,6 +48,7 @@
SUBDIR += innoextract
SUBDIR += javatar
SUBDIR += jzlib
+ SUBDIR += kf5-karchive
SUBDIR += kzip
SUBDIR += laszip
SUBDIR += lbrate
diff --git a/archivers/kf5-karchive/Makefile b/archivers/kf5-karchive/Makefile
new file mode 100644
index 000000000000..2c91a7210219
--- /dev/null
+++ b/archivers/kf5-karchive/Makefile
@@ -0,0 +1,15 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= karchive
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= archivers kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 library that provides classes for handling archive formats
+
+USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
+USE_KDE= ecm
+USE_QT5= buildtools_build core qmake_build
+
+.include <bsd.port.mk>
diff --git a/archivers/kf5-karchive/distinfo b/archivers/kf5-karchive/distinfo
new file mode 100644
index 000000000000..20087842ede5
--- /dev/null
+++ b/archivers/kf5-karchive/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424075
+SHA256 (KDE/frameworks/5.27.0/karchive-5.27.0.tar.xz) = 7f387fa2e0f5360870524d0f2b352179f191d0ed0ea78ec3456964ffab8bebb0
+SIZE (KDE/frameworks/5.27.0/karchive-5.27.0.tar.xz) = 110736
diff --git a/archivers/kf5-karchive/pkg-descr b/archivers/kf5-karchive/pkg-descr
new file mode 100644
index 000000000000..1bc97c399ce3
--- /dev/null
+++ b/archivers/kf5-karchive/pkg-descr
@@ -0,0 +1,7 @@
+KArchive provides classes for easy reading, creation and manipulation of
+"archive" formats like ZIP and TAR.
+
+It also provides transparent compression and decompression of data, like
+the GZip format, via a subclass of QIODevice.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/karchive/html/index.html
diff --git a/archivers/kf5-karchive/pkg-plist b/archivers/kf5-karchive/pkg-plist
new file mode 100644
index 000000000000..e3d11ae0703b
--- /dev/null
+++ b/archivers/kf5-karchive/pkg-plist
@@ -0,0 +1,34 @@
+include/KF5/KArchive/K7Zip
+include/KF5/KArchive/KAr
+include/KF5/KArchive/KArchive
+include/KF5/KArchive/KArchiveDirectory
+include/KF5/KArchive/KArchiveEntry
+include/KF5/KArchive/KArchiveFile
+include/KF5/KArchive/KCompressionDevice
+include/KF5/KArchive/KFilterBase
+include/KF5/KArchive/KFilterDev
+include/KF5/KArchive/KTar
+include/KF5/KArchive/KZip
+include/KF5/KArchive/KZipFileEntry
+include/KF5/KArchive/k7zip.h
+include/KF5/KArchive/kar.h
+include/KF5/KArchive/karchive.h
+include/KF5/KArchive/karchive_export.h
+include/KF5/KArchive/karchivedirectory.h
+include/KF5/KArchive/karchiveentry.h
+include/KF5/KArchive/karchivefile.h
+include/KF5/KArchive/kcompressiondevice.h
+include/KF5/KArchive/kfilterbase.h
+include/KF5/KArchive/kfilterdev.h
+include/KF5/KArchive/ktar.h
+include/KF5/KArchive/kzip.h
+include/KF5/KArchive/kzipfileentry.h
+include/KF5/karchive_version.h
+lib/cmake/KF5Archive/KF5ArchiveConfig.cmake
+lib/cmake/KF5Archive/KF5ArchiveConfigVersion.cmake
+lib/cmake/KF5Archive/KF5ArchiveTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5Archive/KF5ArchiveTargets.cmake
+lib/libKF5Archive.so
+lib/libKF5Archive.so.5
+lib/libKF5Archive.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_MKSPECDIR%%/modules/qt_KArchive.pri