aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2006-05-26 23:53:37 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2006-05-26 23:53:37 +0000
commit5f4c1c7c3caef45c5290ded94c3a0f1da17a983b (patch)
tree0c4a31d790ba00415a3259428f3535a3b1dc6dd0 /archivers
parent9ab82d60d82105cd57c38a2d3d2b00edfb534148 (diff)
downloadports-5f4c1c7c3caef45c5290ded94c3a0f1da17a983b.tar.gz
ports-5f4c1c7c3caef45c5290ded94c3a0f1da17a983b.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/arc/Makefile2
-rw-r--r--archivers/arc/distinfo6
-rw-r--r--archivers/arc/files/patch-al12
3 files changed, 10 insertions, 10 deletions
diff --git a/archivers/arc/Makefile b/archivers/arc/Makefile
index 574211a763b6..cbb9809dfe61 100644
--- a/archivers/arc/Makefile
+++ b/archivers/arc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= arc
-PORTVERSION= 5.21n
+PORTVERSION= 5.21o
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/archivers/arc/distinfo b/archivers/arc/distinfo
index beb27bd6bd7a..f55eb22ea5c2 100644
--- a/archivers/arc/distinfo
+++ b/archivers/arc/distinfo
@@ -1,3 +1,3 @@
-MD5 (arc-5.21n.tgz) = 160eb7b7db1fa0c4b39296b6366a7b66
-SHA256 (arc-5.21n.tgz) = bc270f05b1e7b19085cce3fe4232daa939076828dce5f4077c2bd348d01f9dd4
-SIZE (arc-5.21n.tgz) = 82213
+MD5 (arc-5.21o.tgz) = 3b30c739b42b2fe8ac4ec0a05f34f284
+SHA256 (arc-5.21o.tgz) = 73e6ff87c5c0613d684c7939cdbf7b7a5cd6c393daf956003197dd014bf72fe3
+SIZE (arc-5.21o.tgz) = 82386
diff --git a/archivers/arc/files/patch-al b/archivers/arc/files/patch-al
index 01fc04932fe9..207e33531b82 100644
--- a/archivers/arc/files/patch-al
+++ b/archivers/arc/files/patch-al
@@ -1,5 +1,5 @@
---- arcrun.c.orig Sun Oct 9 03:38:22 2005
-+++ arcrun.c Fri Oct 14 00:53:57 2005
+--- arcrun.c.orig Wed Oct 12 19:22:18 2005
++++ arcrun.c Sat May 27 03:47:30 2006
@@ -98,7 +98,7 @@
strcpy(sys, buf);
@@ -26,11 +26,11 @@
+ if (arcwarn)
if ((tmp = fopen(buf, "r")))
arcdie("Temporary file %s already exists", buf);
- if (!(tmp = fopen(buf, OPEN_W)))
-@@ -148,7 +148,7 @@
+ if (!(tmp = tmpopen(buf)))
+@@ -146,7 +146,7 @@
+ if (system(buf)) /* try to invoke it */
+ arcdie("Execution failed for %s", buf);
#endif
- chdir(dir);
- free(dir); /* return to whence we started */
- if (unlink(buf) && warn) {
+ if (unlink(buf) && arcwarn) {
printf("Cannot unsave temporary file %s\n", buf);