aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 09:56:58 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 09:56:58 +0000
commit9ff4d01a3d0ba549bb48b9c6987de8580ea795c4 (patch)
tree213d40751726304d5eb58e4adc68b7f859dcfc8d /archivers
parent912a19e0c677da3d51cc82bdbdae7e89371b7df3 (diff)
downloadports-9ff4d01a3d0ba549bb48b9c6987de8580ea795c4.tar.gz
ports-9ff4d01a3d0ba549bb48b9c6987de8580ea795c4.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libarc/Makefile2
-rw-r--r--archivers/libcabinet/Makefile2
-rw-r--r--archivers/libcomprex/Makefile2
-rw-r--r--archivers/rpm/Makefile2
-rw-r--r--archivers/ucl/Makefile2
-rw-r--r--archivers/zipios++/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/archivers/libarc/Makefile b/archivers/libarc/Makefile
index e85be38bed34..ce1c38aaf4da 100644
--- a/archivers/libarc/Makefile
+++ b/archivers/libarc/Makefile
@@ -20,7 +20,7 @@ SOVERSION= 1
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I." LN="${LN} -sf" \
SOLIB="${SOLIB}" SOVERSION="${SOVERSION}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
do-install:
$(INSTALL_PROGRAM) ${WRKSRC}/arccat $(PREFIX)/bin
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index ec68e2ebd03f..c5bdcc4785e3 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.bsd-geek.de/FreeBSD/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= A portable library and utility to use Microsoft cabinet files (.cab)
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
diff --git a/archivers/libcomprex/Makefile b/archivers/libcomprex/Makefile
index a6cc8208558c..4fece4645a04 100644
--- a/archivers/libcomprex/Makefile
+++ b/archivers/libcomprex/Makefile
@@ -24,7 +24,7 @@ USE_AUTOTOOLS= libltdl:15
USE_GNOME= gnomehack gnometarget pkgconfig
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index 93d6b31cefec..35e82b4815ab 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -25,7 +25,7 @@ USE_AUTOTOOLS= automake:14 autoconf:213 libtool:15
CONFIGURE_ARGS= --with-glob
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -liconv"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAKE_ENV= OLD_PO_FILE_INPUT=1
MAN1= gendiff.1
diff --git a/archivers/ucl/Makefile b/archivers/ucl/Makefile
index 9b615580ca5a..bdf441fe5997 100644
--- a/archivers/ucl/Makefile
+++ b/archivers/ucl/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.oberhumer.com/opensource/ucl/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A data compression library with low memory usage
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/archivers/zipios++/Makefile b/archivers/zipios++/Makefile
index 3ab6b23610e5..593d7442af39 100644
--- a/archivers/zipios++/Makefile
+++ b/archivers/zipios++/Makefile
@@ -17,7 +17,7 @@ COMMENT= A java.util.zip-like C++ library for reading and writing Zip files
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
# port don't strictly need it, but Wesnoth use it so must we
USE_GCC= 3.4
USE_AUTOTOOLS= automake:19:env