aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 14:34:42 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 14:34:42 +0000
commit9065523e036f73469480e219714c8090f121e666 (patch)
tree628f789e5e3c7c706c11d978fb012aac47b4a7f9 /archivers
parent9cb56c26898d74b8a199abe5f00f96e60c0a6cd6 (diff)
downloadports-9065523e036f73469480e219714c8090f121e666.tar.gz
ports-9065523e036f73469480e219714c8090f121e666.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/lbzip2/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/archivers/lbzip2/Makefile b/archivers/lbzip2/Makefile
index 2bf6c5526930..b125ab789c61 100644
--- a/archivers/lbzip2/Makefile
+++ b/archivers/lbzip2/Makefile
@@ -10,23 +10,19 @@ MAINTAINER= gabor@FreeBSD.org
COMMENT= Multi-threaded bzip2/bunzip2 filter
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= bin/lbzip2
-
-NO_STAGE= yes
-MAN1= lbzip2.1
+PLIST_FILES= bin/lbzip2 \
+ man/man1/lbzip2.1.gz
PORTDOCS= ChangeLog README
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lbzip2 ${PREFIX}/bin/lbzip2
- ${INSTALL_MAN} ${WRKSRC}/lbzip2.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/lbzip2 ${STAGEDIR}${PREFIX}/bin/lbzip2
+ ${INSTALL_MAN} ${WRKSRC}/lbzip2.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>