aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-08-13 05:55:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-08-13 05:55:54 +0000
commite5ddaf6a72b66d8f0786c4de3db00658e39fbe9e (patch)
tree48dce19ad331bde6876a0e8868088bceb91d877b /archivers
parentd834c4b5a938f00a20e4164313eb38be2138153c (diff)
downloadports-e5ddaf6a72b66d8f0786c4de3db00658e39fbe9e.tar.gz
ports-e5ddaf6a72b66d8f0786c4de3db00658e39fbe9e.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/squeeze/Makefile52
-rw-r--r--archivers/squeeze/distinfo3
-rw-r--r--archivers/squeeze/pkg-descr5
-rw-r--r--archivers/squeeze/pkg-plist57
5 files changed, 118 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 85bcea6e9276..89bcc141555d 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -160,6 +160,7 @@
SUBDIR += rzip
SUBDIR += sectar
SUBDIR += sharutils
+ SUBDIR += squeeze
SUBDIR += squsq
SUBDIR += star
SUBDIR += stuffit
diff --git a/archivers/squeeze/Makefile b/archivers/squeeze/Makefile
new file mode 100644
index 000000000000..3a45dc260b1c
--- /dev/null
+++ b/archivers/squeeze/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: squeeze
+# Date created: 07 Jun 2010
+# Whom: markand
+#
+# $FreeBSD$
+#
+
+PORTNAME= squeeze
+PORTVERSION= 0.2.3
+CATEGORIES= archivers xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= markand@malikania.fr
+COMMENT= Squeeze is a modern and advanced archive manager
+
+MAKE_JOB_SAFE= yes
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+USE_XFCE= configenv panel thunar
+USE_XORG= x11
+USE_GNOME= gnomehack gnometarget gtk20 glib20 intltool intlhack pkgconfig
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+
+OPTIONS= GTKDOC "Enable GTK html documentation" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GTKDOC)
+PLIST_SUB= GTKDOC=""
+.else
+PLIST_SUB= GTKDOC="@comment "
+.endif
+
+post-patch:
+# Needed to remove gtk-doc installation
+.if !defined(WITH_GTKDOC)
+ @${REINPLACE_CMD} -e "s|docs||g" ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/archivers/squeeze/distinfo b/archivers/squeeze/distinfo
new file mode 100644
index 000000000000..2a5d7ca474c2
--- /dev/null
+++ b/archivers/squeeze/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4/squeeze-0.2.3.tar.bz2) = bd3cb0648b49be1f146fc4f675606176
+SHA256 (xfce4/squeeze-0.2.3.tar.bz2) = 7b8dc13e0adf72c67bba12e1ed1285ec820946e65d0eec247f7bd159a2cfac2d
+SIZE (xfce4/squeeze-0.2.3.tar.bz2) = 418023
diff --git a/archivers/squeeze/pkg-descr b/archivers/squeeze/pkg-descr
new file mode 100644
index 000000000000..0594c546326d
--- /dev/null
+++ b/archivers/squeeze/pkg-descr
@@ -0,0 +1,5 @@
+Squeeze is a modern and advanced archive manager for the Xfce Desktop
+Environment. Its design adheres to the Xfce philosophy, which basically
+means Squeeze is designed to be both fast and easy to use.
+
+WWW: http://squeeze.xfce.org/
diff --git a/archivers/squeeze/pkg-plist b/archivers/squeeze/pkg-plist
new file mode 100644
index 000000000000..c1304c03c929
--- /dev/null
+++ b/archivers/squeeze/pkg-plist
@@ -0,0 +1,57 @@
+bin/squeeze
+include/libsqueeze-0.2/libsqueeze/libsqueeze-archive.h
+include/libsqueeze-0.2/libsqueeze/libsqueeze-command.h
+include/libsqueeze-0.2/libsqueeze/libsqueeze-module.h
+include/libsqueeze-0.2/libsqueeze/libsqueeze-vfs-mime.h
+include/libsqueeze-0.2/libsqueeze/libsqueeze-view.h
+include/libsqueeze-0.2/libsqueeze/libsqueeze.h
+lib/libsqueeze-0.2.so.0
+lib/libsqueeze-0.2.so
+lib/libsqueeze-0.2.la
+lib/libsqueeze-0.2.a
+libdata/pkgconfig/libsqueeze-0.2.pc
+libexec/thunar-archive-plugin/squeeze.tap
+share/locale/ar/LC_MESSAGES/squeeze.mo
+share/locale/be/LC_MESSAGES/squeeze.mo
+share/locale/ca/LC_MESSAGES/squeeze.mo
+share/locale/cs/LC_MESSAGES/squeeze.mo
+share/locale/el/LC_MESSAGES/squeeze.mo
+share/locale/en_GB/LC_MESSAGES/squeeze.mo
+share/locale/eu/LC_MESSAGES/squeeze.mo
+share/locale/fi/LC_MESSAGES/squeeze.mo
+share/locale/fr/LC_MESSAGES/squeeze.mo
+share/locale/hu/LC_MESSAGES/squeeze.mo
+share/locale/nl/LC_MESSAGES/squeeze.mo
+share/locale/pa/LC_MESSAGES/squeeze.mo
+share/locale/pt_BR/LC_MESSAGES/squeeze.mo
+share/locale/ru/LC_MESSAGES/squeeze.mo
+share/locale/sq/LC_MESSAGES/squeeze.mo
+share/locale/tr/LC_MESSAGES/squeeze.mo
+share/locale/uk/LC_MESSAGES/squeeze.mo
+share/pixmaps/squeeze/archive-add.png
+share/pixmaps/squeeze/archive-extract.png
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/LSQArchive.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/LSQArchiveCommand.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/archiving.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/home.png
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/index.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/index.sgml
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/ix01.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/left.png
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/libsqueeze-LSQArchiveSupport.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/libsqueeze-libsqueeze.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/libsqueeze.devhelp
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/libsqueeze.devhelp2
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/libsqueeze.html
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/right.png
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/style.css
+%%GTKDOC%%share/gtk-doc/html/libsqueeze/up.png
+share/icons/hicolor/16x16/apps/squeeze.png
+share/icons/hicolor/48x48/apps/squeeze.png
+share/icons/hicolor/scalable/apps/squeeze.svg
+share/applications/squeeze.desktop
+@dirrmtry share/pixmaps/squeeze
+@dirrmtry share/gtk-doc/html/libsqueeze
+@dirrmtry libexec/thunar-archive-plugin
+@dirrmtry include/libsqueeze-0.2/libsqueeze
+@dirrmtry include/libsqueeze-0.2