aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-11-25 15:48:57 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-11-25 15:48:57 +0000
commit31f3c6a65642ef3230648a6282a7d9f0a3f655dd (patch)
treebff7f87d972ce9a039f5920f9c3c690f9b112e5a /archivers
parent9e6092dc009d0b3e769aecc65bdcdf966cdcd53b (diff)
downloadports-31f3c6a65642ef3230648a6282a7d9f0a3f655dd.tar.gz
ports-31f3c6a65642ef3230648a6282a7d9f0a3f655dd.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/php5-phar/Makefile14
-rw-r--r--archivers/php5-phar/files/patch-config.m441
-rw-r--r--archivers/php5-phar/files/patch-phar.c11
4 files changed, 67 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index b80bc0eb1d0a..fe768f2b27d3 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -132,6 +132,7 @@
SUBDIR += php4-bz2
SUBDIR += php4-zlib
SUBDIR += php5-bz2
+ SUBDIR += php5-phar
SUBDIR += php5-zip
SUBDIR += php5-zlib
SUBDIR += php52-bz2
diff --git a/archivers/php5-phar/Makefile b/archivers/php5-phar/Makefile
new file mode 100644
index 000000000000..6587ae6c572e
--- /dev/null
+++ b/archivers/php5-phar/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php5-phar
+# Date created: 25 Nov 2011
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php5
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php5-phar/files/patch-config.m4 b/archivers/php5-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1a981bfefdc1
--- /dev/null
+++ b/archivers/php5-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2011-11-25 15:31:20.000000000 +0100
++++ config.m4 2011-11-25 15:47:45.000000000 +0100
+@@ -4,8 +4,38 @@
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php5-phar/files/patch-phar.c b/archivers/php5-phar/files/patch-phar.c
new file mode 100644
index 000000000000..231ec40a8423
--- /dev/null
+++ b/archivers/php5-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2011-11-25 15:38:44.000000000 +0100
++++ phar.c 2011-11-25 15:39:01.000000000 +0100
+@@ -3716,7 +3716,7 @@
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL