aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-04-27 08:50:46 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-04-27 08:50:46 +0000
commit821843ca06f2354ffe250825fcdffabb6d0caefa (patch)
tree5b8de344e457d5da2cf746d56e495a2ce03e1d99 /archivers
parent89d548370ac959aac24d63bd8ab8e32723ecf53d (diff)
downloadports-821843ca06f2354ffe250825fcdffabb6d0caefa.tar.gz
ports-821843ca06f2354ffe250825fcdffabb6d0caefa.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/dpkg/Makefile2
-rw-r--r--archivers/gtar/Makefile2
-rw-r--r--archivers/liborange/Makefile2
-rw-r--r--archivers/rpm4/Makefile3
-rw-r--r--archivers/rpm5/Makefile3
-rw-r--r--archivers/star/Makefile3
-rw-r--r--archivers/unalz/Makefile2
-rw-r--r--archivers/unrar-iconv/Makefile2
-rw-r--r--archivers/unzip/Makefile2
9 files changed, 9 insertions, 12 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index f4a52bddc8b4..9f9b8c953079 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -19,10 +19,10 @@ BUILD_DEPENDS= po4a:${PORTSDIR}/textproc/po4a
RUN_DEPENDS= gmd5sum:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch
+USES= iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_ICONV= yes
USE_PERL5= yes
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
diff --git a/archivers/gtar/Makefile b/archivers/gtar/Makefile
index 2221562370f5..f78a99a7e85b 100644
--- a/archivers/gtar/Makefile
+++ b/archivers/gtar/Makefile
@@ -16,9 +16,9 @@ COMMENT= GNU version of the traditional tape archiver
INFO= tar
+USES= iconv
USE_AUTOTOOLS= autoconf:env # autom4te
USE_XZ= yes
-USE_ICONV= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --program-prefix=g \
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index 48712d2cae46..cbb0787e3248 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -25,7 +25,7 @@ MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= iconv pathfix pkgconfig
USE_ICONV= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index df1230c34c6a..cb5d0bdbe818 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -61,8 +61,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-USE_ICONV= yes
+USES+= gettext iconv
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index 982c3aeb37c6..eb2444f2fc37 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -76,8 +76,7 @@ PLIST_SUB+= PYTHON="@comment "
.if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+=--enable-nls
-USES+= gettext
-USE_ICONV= yes
+USES+= gettext iconv
.else
CONFIGURE_ARGS+=--disable-nls
.endif
diff --git a/archivers/star/Makefile b/archivers/star/Makefile
index 22d16c650a9e..38be9a173935 100644
--- a/archivers/star/Makefile
+++ b/archivers/star/Makefile
@@ -12,8 +12,7 @@ COMMENT= Unique standard tape archiver with many enhancements
BUILD_DEPENDS= smake:${PORTSDIR}/devel/smake
USE_BZIP2= yes
-USES= gettext
-USE_ICONV= yes
+USES= gettext iconv
.if !defined(NO_INSTALL_MANPAGES)
MAN1= scpio.1 spax.1 srmt.1 star.1 suntar.1 tartest.1
diff --git a/archivers/unalz/Makefile b/archivers/unalz/Makefile
index 02940c6cc214..3a0c18530e37 100644
--- a/archivers/unalz/Makefile
+++ b/archivers/unalz/Makefile
@@ -14,7 +14,7 @@ COMMENT= Extracts AlZip archives
LICENSE_FILE= ${WRKSRC}/readme.txt
BROKEN= fails to build
-USE_ICONV= yes
+USES= iconv
PLIST_FILES= bin/unalz
MAKEFILE= Makefile.freebsd
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/archivers/unrar-iconv/Makefile b/archivers/unrar-iconv/Makefile
index be13be93ee68..7bcc102df9a5 100644
--- a/archivers/unrar-iconv/Makefile
+++ b/archivers/unrar-iconv/Makefile
@@ -15,7 +15,7 @@ EXTRA_PATCHES= ${.CURDIR}/files/patch-iconv
CPPFLAGS+= -DWITH_ICONV -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
-USE_ICONV= yes
+USES+= iconv
CONFLICTS= unrar-[0-9]* zh-unrar-[0-9]*
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 7c943c1d5ea6..a42b57c3d0fe 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -50,7 +50,7 @@ PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= nork
PATCHFILES+= unzip60-alt-iconv-utf8.patch
PATCH_DIST_STRIP+= -p1
-USE_ICONV= yes
+USES= iconv
CFLAGS+= -I${LOCALBASE}/include -DNATIVE
MAKE_ARGS+= LFLAGS1="-L${LOCALBASE}/lib -liconv"
.endif