aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-01-25 16:55:09 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-01-25 16:55:09 +0000
commit2e676175ca5b0e516f1b0338cf0657f228a64115 (patch)
tree0285c971acecbcbc7a0b60dc7900a5e4ba6760a7 /archivers
parent61c886f0edb54199505954513b54ba98a846d198 (diff)
downloadports-2e676175ca5b0e516f1b0338cf0657f228a64115.tar.gz
ports-2e676175ca5b0e516f1b0338cf0657f228a64115.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/xar/Makefile37
-rw-r--r--archivers/xar/distinfo3
-rw-r--r--archivers/xar/files/patch-include_xar.h.in10
-rw-r--r--archivers/xar/pkg-descr11
-rw-r--r--archivers/xar/pkg-plist5
6 files changed, 67 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 191aaf9d4237..e9d8ed7d93d0 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -111,6 +111,7 @@
SUBDIR += unzoo
SUBDIR += upx
SUBDIR += wzip
+ SUBDIR += xar
SUBDIR += xarchive
SUBDIR += xdms
SUBDIR += xmill
diff --git a/archivers/xar/Makefile b/archivers/xar/Makefile
new file mode 100644
index 000000000000..1082b47e7a0f
--- /dev/null
+++ b/archivers/xar/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xar
+# Date created: 24 January 2005
+# Whom: Jeffrey H. Johnson <CPE1704TKS@bellsouth.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xar
+DISTVERSION= 1.3
+CATEGORIES= archivers
+MASTER_SITES= http://www.opendarwin.org/projects/xar/ \
+ http://distfiles-msn.opendarwin.org/ \
+ http://distfiles-od.opendarwin.org/ \
+ http://distfiles.opendarwin.org/
+
+MAINTAINER= CPE1704TKS@bellsouth.net
+COMMENT= OpenDarwin XML eXtensible ARchiver
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+INSTALLS_SHLIB= yes
+
+USE_GNOME= libxml2
+USE_GMAKE= yes
+USE_OPENSSL= yes
+
+GNU_CONFIGURE= yes
+
+MAN1= xar.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on FreeBSD < 5.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/xar/distinfo b/archivers/xar/distinfo
new file mode 100644
index 000000000000..8b93d6adf658
--- /dev/null
+++ b/archivers/xar/distinfo
@@ -0,0 +1,3 @@
+MD5 (xar-1.3.tar.gz) = 757103c9abeef77004a86af55a01452b
+SHA256 (xar-1.3.tar.gz) = 654263d29dfe079dde2cb1b30cb208aa81b5b338135b25315c1e5d1325a66dd2
+SIZE (xar-1.3.tar.gz) = 114402
diff --git a/archivers/xar/files/patch-include_xar.h.in b/archivers/xar/files/patch-include_xar.h.in
new file mode 100644
index 000000000000..8914328f8fb6
--- /dev/null
+++ b/archivers/xar/files/patch-include_xar.h.in
@@ -0,0 +1,10 @@
+--- include/xar.h.in.orig Tue Jan 24 02:14:31 2006
++++ include/xar.h.in Tue Jan 24 02:14:45 2006
+@@ -36,6 +36,7 @@
+
+ #define XAR_VERSION "@XAR_VERSION@"
+
++#include <sys/limits.h>
+ #include <sys/types.h>
+ #include <stdint.h>
+
diff --git a/archivers/xar/pkg-descr b/archivers/xar/pkg-descr
new file mode 100644
index 000000000000..7a2670ccdc87
--- /dev/null
+++ b/archivers/xar/pkg-descr
@@ -0,0 +1,11 @@
+The XAR project aims to provide an easily extensible archive format.
+Important design decisions include an easily extensible XML table of
+contents for random access to archived files, storing the toc at the
+beginning of the archive to allow for efficient handling of streamed
+archives, the ability to handle files of arbitrarily large sizes,
+the ability to choose independent encodings for individual files in
+the archive, the ability to store checksums for individual files in
+both compressed and uncompressed form, and the ability to query the
+table of content's rich meta-data.
+
+WWW: http://www.opendarwin.org/projects/xar/
diff --git a/archivers/xar/pkg-plist b/archivers/xar/pkg-plist
new file mode 100644
index 000000000000..0a783c4d8d4f
--- /dev/null
+++ b/archivers/xar/pkg-plist
@@ -0,0 +1,5 @@
+bin/xar
+include/xar/xar.h
+lib/libxar.so.1
+lib/libxar.so
+@dirrm include/xar