aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-02 17:51:24 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-02 17:51:24 +0000
commitf3f7446a00538cc58e3342c0def011efd48593d8 (patch)
tree040cad918af9073803a4db29c8d6576701def55c /archivers
parente7118c767e51c4b6c82dfadae8b00feb861d366a (diff)
downloadports-f3f7446a00538cc58e3342c0def011efd48593d8.tar.gz
ports-f3f7446a00538cc58e3342c0def011efd48593d8.zip
archivers/c-blosc2: fix build on powerpc64le
In file included from /wrkdirs/usr/ports/archivers/c-blosc2/work/c-blosc2-2.0.4/plugins/codecs/ndlz/xxhash.h:2937: /usr/lib/clang/11.0.1/include/altivec.h:55:19: error: unknown type name 'vector' static __inline__ vector bool char __ATTRS_o_ai
Diffstat (limited to 'archivers')
-rw-r--r--archivers/c-blosc2/files/patch-CMakeLists.txt11
-rw-r--r--archivers/c-blosc2/files/patch-plugins_codecs_ndlz_xxhash.h10
2 files changed, 21 insertions, 0 deletions
diff --git a/archivers/c-blosc2/files/patch-CMakeLists.txt b/archivers/c-blosc2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7807ca6dfb7e
--- /dev/null
+++ b/archivers/c-blosc2/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2021-11-02 17:39:13 UTC
++++ CMakeLists.txt
+@@ -303,7 +303,7 @@ elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL armv7l OR
+ # Unrecognized compiler. Emit a warning message to let the user know hardware-acceleration won't be available.
+ message(WARNING "Unable to determine which ${CMAKE_SYSTEM_PROCESSOR} hardware features are supported by the C compiler (${CMAKE_C_COMPILER_ID} ${CMAKE_C_COMPILER_VERSION}).")
+ endif()
+-elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL ppc64le)
++elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL "^(ppc64le|powerpc64le)")
+ if(CMAKE_C_COMPILER_ID STREQUAL GNU AND CMAKE_C_COMPILER_VERSION VERSION_GREATER 8)
+ set(COMPILER_SUPPORT_ALTIVEC TRUE)
+ else()
diff --git a/archivers/c-blosc2/files/patch-plugins_codecs_ndlz_xxhash.h b/archivers/c-blosc2/files/patch-plugins_codecs_ndlz_xxhash.h
new file mode 100644
index 000000000000..1e375ef9da1e
--- /dev/null
+++ b/archivers/c-blosc2/files/patch-plugins_codecs_ndlz_xxhash.h
@@ -0,0 +1,10 @@
+--- plugins/codecs/ndlz/xxhash.h.orig 2021-10-02 12:17:56 UTC
++++ plugins/codecs/ndlz/xxhash.h
+@@ -2934,6 +2934,7 @@ enum XXH_VECTOR_TYPE /* fake enum */ {
+ # if defined(__GNUC__) && !defined(__APPLE_ALTIVEC__)
+ # define __APPLE_ALTIVEC__
+ # endif
++# define vector __vector
+ # include <altivec.h>
+ # endif
+