aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-03-02 17:49:36 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-03-26 09:20:18 +0000
commit8a56a24e868fd924c4f5fb511b31dcdcfbe7aec2 (patch)
tree7840885fb2dc24132145a660dd1f59a02267dec1 /archivers
parent6804aa8f7c5ecbdc86095a7553a7e3acd2136098 (diff)
downloadports-8a56a24e868fd924c4f5fb511b31dcdcfbe7aec2.tar.gz
ports-8a56a24e868fd924c4f5fb511b31dcdcfbe7aec2.zip
archivers/py-bup: upgrade to 0.32
This release should work with Python-3.9. Release notes at <https://github.com/bup/bup/blob/master/note/0.32-from-0.31.md>. PR: 262303 Approved by: maintainer’s time-out
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-bup/Makefile6
-rw-r--r--archivers/py-bup/distinfo6
-rw-r--r--archivers/py-bup/files/patch-Makefile12
-rw-r--r--archivers/py-bup/files/patch-config_configure15
-rw-r--r--archivers/py-bup/files/patch-test_ext_test-sparse-files (renamed from archivers/py-bup/files/patch-t_test-sparse-files.sh)6
5 files changed, 22 insertions, 23 deletions
diff --git a/archivers/py-bup/Makefile b/archivers/py-bup/Makefile
index c1c04d0cbdff..d1ebf231faa9 100644
--- a/archivers/py-bup/Makefile
+++ b/archivers/py-bup/Makefile
@@ -1,7 +1,7 @@
# Created by: José García Juanino <jjuanino@gmail.com>
PORTNAME= bup
-PORTVERSION= 0.31
+PORTVERSION= 0.32
CATEGORIES= archivers python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,9 +17,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pylibacl>0:security/py-pylibacl@${PY_FLAVOR}
par2cmdline>0.4:archivers/par2cmdline
BUILD_DEPENDS= bash:shells/bash \
git>1.5.6:devel/git
+RUN_DEPENDS= bash:shells/bash
-USES= python:3.6+ gmake
+USES= gmake python:3.6+ shebangfix
USE_PYTHON= autoplist
+SHEBANG_FILES= test/ext/test-sparse-files lib/cmd/import-rdiff-backup-cmd.sh
PLIST_SUB= MANDIR=${PREFIX}/share/man
diff --git a/archivers/py-bup/distinfo b/archivers/py-bup/distinfo
index 5274ed8ba9a9..08423a93dfb3 100644
--- a/archivers/py-bup/distinfo
+++ b/archivers/py-bup/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608064432
-SHA256 (bup-bup-0.31_GH0.tar.gz) = 2f54351aed653b4b9567d3a534af598a5bc63b32efd7cc593bcecac3b89e16d1
-SIZE (bup-bup-0.31_GH0.tar.gz) = 454636
+TIMESTAMP = 1646238825
+SHA256 (bup-bup-0.32_GH0.tar.gz) = a894cfa96c44b9ef48003b2c2104dc5fa6361dd2f4d519261a93178984a51259
+SIZE (bup-bup-0.32_GH0.tar.gz) = 448487
diff --git a/archivers/py-bup/files/patch-Makefile b/archivers/py-bup/files/patch-Makefile
index 83685eaab391..a06868c66112 100644
--- a/archivers/py-bup/files/patch-Makefile
+++ b/archivers/py-bup/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig 2020-12-15 12:37:40.871053000 -0800
-+++ Makefile 2020-12-15 12:38:46.984653000 -0800
-@@ -28,7 +28,7 @@
+--- Makefile.orig 2021-01-09 22:11:10 UTC
++++ Makefile
+@@ -28,7 +28,7 @@ current_sampledata := test/sampledata/var/rev/v$(sampl
os := $(shell ($(pf); uname | sed 's/[-_].*//') $(isok))
os := $(call shout,$(os),Unable to determine OS)
--CFLAGS := -Wall -Wformat=2 -O2 -Werror -Wno-unknown-pragmas $(CFLAGS)
-+CFLAGS := -Wall -O2 -Wno-unknown-pragmas $(PYINCLUDE) $(CFLAGS)
+-CFLAGS := -O2 -Wall -Werror -Wformat=2 $(CFLAGS)
++CFLAGS := -Wall $(CFLAGS)
+ CFLAGS := -Wno-unknown-pragmas -Wsign-compare $(CFLAGS)
CFLAGS := -D_FILE_OFFSET_BITS=64 $(PYINCLUDE) $(CFLAGS)
SOEXT:=.so
-
diff --git a/archivers/py-bup/files/patch-config_configure b/archivers/py-bup/files/patch-config_configure
index e0db82ed7f27..71df44071322 100644
--- a/archivers/py-bup/files/patch-config_configure
+++ b/archivers/py-bup/files/patch-config_configure
@@ -1,13 +1,10 @@
---- config/configure.orig 2020-12-15 16:52:00.017999000 -0800
-+++ config/configure 2020-12-15 16:53:04.758080000 -0800
-@@ -66,6 +66,10 @@
+--- config/configure.orig 2021-01-09 22:11:10 UTC
++++ config/configure
+@@ -66,6 +66,7 @@ expr "$MAKE_VERSION" '>=' '3.81' || AC_FAIL "ERROR: $M
AC_SUB bup_make "$MAKE"
bup_python="$(type -p "$PYTHON")"
+test -z "$bup_python" && bup_python="$(bup_find_prog python3.9 '')"
-+test -z "$bup_python" && bup_python="$(bup_find_prog python3.8 '')"
-+test -z "$bup_python" && bup_python="$(bup_find_prog python3.7 '')"
-+test -z "$bup_python" && bup_python="$(bup_find_prog python3.6 '')"
- test -z "$bup_python" && bup_python="$(bup_find_prog python2.7 '')"
- test -z "$bup_python" && bup_python="$(bup_find_prog python2.6 '')"
- test -z "$bup_python" && bup_python="$(bup_find_prog python2 '')"
+ test -z "$bup_python" && bup_python="$(bup_find_prog python3.8 '')"
+ test -z "$bup_python" && bup_python="$(bup_find_prog python3.7 '')"
+ test -z "$bup_python" && bup_python="$(bup_find_prog python3.6 '')"
diff --git a/archivers/py-bup/files/patch-t_test-sparse-files.sh b/archivers/py-bup/files/patch-test_ext_test-sparse-files
index 3df7cb548932..08f6217a45df 100644
--- a/archivers/py-bup/files/patch-t_test-sparse-files.sh
+++ b/archivers/py-bup/files/patch-test_ext_test-sparse-files
@@ -1,6 +1,6 @@
---- t/test-sparse-files.sh.orig 2020-12-15 12:42:46.593767000 -0800
-+++ t/test-sparse-files.sh 2020-12-15 12:43:10.570419000 -0800
-@@ -31,6 +31,12 @@
+--- test/ext/test-sparse-files.orig 2021-01-09 22:11:10 UTC
++++ test/ext/test-sparse-files
+@@ -31,6 +31,12 @@ if [ "$probe_size" -ge "$((data_size / 1024))" ]; then
exit 0
fi