aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2021-10-29 14:58:50 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2022-02-23 07:46:05 +0000
commita6b6ca53e5f670a812628fd7f71461f7ac87989a (patch)
treec846aa233b445a8eeb77d9bd268a223cabd6d819 /archivers
parenta0fd925c724ceb0ad71ee904a20e6d64b1a467ba (diff)
downloadports-a6b6ca53e5f670a812628fd7f71461f7ac87989a.tar.gz
ports-a6b6ca53e5f670a812628fd7f71461f7ac87989a.zip
archivers/py-python-rpm-packaging: python rpm packaging
Python helpers and scripts used by archivers/rpm4 4.17.0 for python packaging.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-python-rpm-packaging/Makefile38
-rw-r--r--archivers/py-python-rpm-packaging/distinfo3
-rw-r--r--archivers/py-python-rpm-packaging/pkg-descr3
4 files changed, 45 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 2137d7ba25e3..f8e7f1309667 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -185,6 +185,7 @@
SUBDIR += py-lzstring
SUBDIR += py-python-lhafile
SUBDIR += py-python-lzo
+ SUBDIR += py-python-rpm-packaging
SUBDIR += py-python-snappy
SUBDIR += py-rarfile
SUBDIR += py-rcssmin
diff --git a/archivers/py-python-rpm-packaging/Makefile b/archivers/py-python-rpm-packaging/Makefile
new file mode 100644
index 000000000000..97b1360e684a
--- /dev/null
+++ b/archivers/py-python-rpm-packaging/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= python-rpm-packaging
+PORTVERSION= 0.0.20210526
+CATEGORIES= archivers python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rodrigo@FreeBSD.org
+COMMENT= Python rpm packaging
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyyaml-include>0:devel/py-pyyaml-include@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= rpm-software-management
+GH_PROJECT= python-rpm-packaging
+GH_TAGNAME= a18ca48959c95aefa725317084dd2d3e242e4f71
+
+SHEBANG_FILES= scripts/brp-python-bytecompile scripts/pythondistdeps.py
+NO_BUILD= yes
+
+PLIST_FILES= lib/rpm/brp-python-bytecompile \
+ lib/rpm/brp-python-hardlink \
+ lib/rpm/pythondistdeps.py
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/rpm/
+.for l in brp-python-bytecompile brp-python-hardlink pythondistdeps.py
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${l} ${STAGEDIR}${PREFIX}/lib/rpm/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/archivers/py-python-rpm-packaging/distinfo b/archivers/py-python-rpm-packaging/distinfo
new file mode 100644
index 000000000000..4c965db232a0
--- /dev/null
+++ b/archivers/py-python-rpm-packaging/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1635496540
+SHA256 (rpm-software-management-python-rpm-packaging-0.0.20210526-a18ca48959c95aefa725317084dd2d3e242e4f71_GH0.tar.gz) = bc39fe7d09ebda56292c825e7ce2cce77491b6ca7a6c674612e18aafe5f1e6f8
+SIZE (rpm-software-management-python-rpm-packaging-0.0.20210526-a18ca48959c95aefa725317084dd2d3e242e4f71_GH0.tar.gz) = 35144
diff --git a/archivers/py-python-rpm-packaging/pkg-descr b/archivers/py-python-rpm-packaging/pkg-descr
new file mode 100644
index 000000000000..d8670203d5de
--- /dev/null
+++ b/archivers/py-python-rpm-packaging/pkg-descr
@@ -0,0 +1,3 @@
+Python rpm packaging helpers and scripts
+
+WWW: https://github.com/rpm-software-management/python-rpm-packaging