aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-19 01:39:47 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-19 01:39:47 +0000
commitd94a4c6c5c58e34eab673052d1368f05464a5d39 (patch)
tree8f7f07c64cb36d80b5861ec0b761b57b44866d87 /archivers
parentb3dac5f9c2b1d92d4818cf8a850a269f9bbc1597 (diff)
downloadports-d94a4c6c5c58e34eab673052d1368f05464a5d39.tar.gz
ports-d94a4c6c5c58e34eab673052d1368f05464a5d39.zip
archivers/c-blosc2: correct ppc64le condition
MATCHES should be used to allow for a regular expression. STREQUAL was using the expression as a literal string.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/c-blosc2/Makefile1
-rw-r--r--archivers/c-blosc2/files/patch-CMakeLists.txt2
2 files changed, 2 insertions, 1 deletions
diff --git a/archivers/c-blosc2/Makefile b/archivers/c-blosc2/Makefile
index 6ce38b81dd06..8472bf185f66 100644
--- a/archivers/c-blosc2/Makefile
+++ b/archivers/c-blosc2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= c-blosc2
PORTVERSION= 2.0.4
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= archivers
diff --git a/archivers/c-blosc2/files/patch-CMakeLists.txt b/archivers/c-blosc2/files/patch-CMakeLists.txt
index 7807ca6dfb7e..225e7f49f0ce 100644
--- a/archivers/c-blosc2/files/patch-CMakeLists.txt
+++ b/archivers/c-blosc2/files/patch-CMakeLists.txt
@@ -5,7 +5,7 @@
message(WARNING "Unable to determine which ${CMAKE_SYSTEM_PROCESSOR} hardware features are supported by the C compiler (${CMAKE_C_COMPILER_ID} ${CMAKE_C_COMPILER_VERSION}).")
endif()
-elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL ppc64le)
-+elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL "^(ppc64le|powerpc64le)")
++elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(ppc64le|powerpc64le)")
if(CMAKE_C_COMPILER_ID STREQUAL GNU AND CMAKE_C_COMPILER_VERSION VERSION_GREATER 8)
set(COMPILER_SUPPORT_ALTIVEC TRUE)
else()