aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
commite482e392f687b2248d2975d68327324a858e1273 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /archivers
parent5183b406511b98ffef72263a3609234aaaa0d4fb (diff)
downloadports-e482e392f687b2248d2975d68327324a858e1273.tar.gz
ports-e482e392f687b2248d2975d68327324a858e1273.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/dpkg/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index e144dd4c4aa9..ddb9a1819a5b 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -16,10 +16,9 @@ BUILD_DEPENDS= po4a:${PORTSDIR}/textproc/po4a
RUN_DEPENDS= gmd5sum:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch
-USES= iconv
+USES= gmake iconv
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_PERL5= yes
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
@@ -35,15 +34,16 @@ CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
--disable-compiler-warnings
CONFIGURE_ENV+= PERL_LIBDIR="${PREFIX}/${SITE_PERL_REL}"
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_OFF= --disable-nls
+NLS_USES= gettext
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
MANLANG= "" de fr hu ja pl sv
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
.include "Makefile.man"