aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-25 14:22:28 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-25 14:22:28 +0000
commit0ed430cc6b0e15a634b816851a9d276732c845e5 (patch)
treec635ef08d1f328a72978ba533b1dba4060dee2d3 /archivers
parent4ee78656943924aa6486525644f13c15d3c1d31a (diff)
downloadports-0ed430cc6b0e15a634b816851a9d276732c845e5.tar.gz
ports-0ed430cc6b0e15a634b816851a9d276732c845e5.zip
Build and install pzstd
- While I'm here: - Use MAKE_CMD instead of GMAKE - Use post-install: instead of post-stage: - Respect PREFIX - Bump PORTREVISION for package change PR: 218869 Submitted by: eugen
Notes
Notes: svn path=/head/; revision=439383
Diffstat (limited to 'archivers')
-rw-r--r--archivers/zstd/Makefile7
-rw-r--r--archivers/zstd/pkg-plist1
2 files changed, 8 insertions, 0 deletions
diff --git a/archivers/zstd/Makefile b/archivers/zstd/Makefile
index 2bed432c17d4..b4e3f4127be2 100644
--- a/archivers/zstd/Makefile
+++ b/archivers/zstd/Makefile
@@ -4,6 +4,7 @@
PORTNAME= zstd
PORTVERSION= 1.1.4
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= archivers
MAINTAINER= sunpoet@FreeBSD.org
@@ -24,4 +25,10 @@ USE_GITHUB= yes
post-patch:
@${REINPLACE_CMD} -e 's|INSTALL_|BSD_&|' ${WRKSRC}/lib/Makefile ${WRKSRC}/programs/Makefile
+post-build:
+ ${MAKE_CMD} -C ${WRKSRC}/contrib/pzstd/
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/contrib/pzstd/pzstd ${STAGEDIR}${PREFIX}/bin/
+
.include <bsd.port.mk>
diff --git a/archivers/zstd/pkg-plist b/archivers/zstd/pkg-plist
index ab3e4711b436..bd56cbb699f2 100644
--- a/archivers/zstd/pkg-plist
+++ b/archivers/zstd/pkg-plist
@@ -1,3 +1,4 @@
+bin/pzstd
bin/unzstd
bin/zstd
bin/zstdcat