aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-18 17:51:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-18 17:51:38 +0000
commit310beeb63c231d3e8fd1d51d63d46b78076fe2d3 (patch)
treefe0c6e11507357ecf8b4640b9f17498a2f2e9780 /archivers
parent38fdd02e106b3943f177b74faf38637acbec477d (diff)
downloadports-310beeb63c231d3e8fd1d51d63d46b78076fe2d3.tar.gz
ports-310beeb63c231d3e8fd1d51d63d46b78076fe2d3.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/p5-Compress-Snappy/Makefile29
-rw-r--r--archivers/p5-Compress-Snappy/distinfo2
-rw-r--r--archivers/p5-Compress-Snappy/pkg-descr9
-rw-r--r--archivers/p5-Compress-Snappy/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index d99aadc79943..75a6f2c803d1 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -104,6 +104,7 @@
SUBDIR += p5-Compress-Raw-Bzip2
SUBDIR += p5-Compress-Raw-Lzma
SUBDIR += p5-Compress-Raw-Zlib
+ SUBDIR += p5-Compress-Snappy
SUBDIR += p5-IO-Compress
SUBDIR += p5-IO-Compress-Lzf
SUBDIR += p5-IO-Compress-Lzma
diff --git a/archivers/p5-Compress-Snappy/Makefile b/archivers/p5-Compress-Snappy/Makefile
new file mode 100644
index 000000000000..8dc8d05dd756
--- /dev/null
+++ b/archivers/p5-Compress-Snappy/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Compress-Snappy
+# Date created: 2012-01-07
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Compress-Snappy
+PORTVERSION= 0.18
+CATEGORIES= archivers perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Perl interface to Google Snappy (de)compressor
+
+LIB_DEPENDS= snappy:${PORTSDIR}/archivers/snappy
+
+PERL_CONFIGURE= yes
+
+MAN3= Compress::Snappy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/p5-Compress-Snappy/distinfo b/archivers/p5-Compress-Snappy/distinfo
new file mode 100644
index 000000000000..c7baa7cec31b
--- /dev/null
+++ b/archivers/p5-Compress-Snappy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Compress-Snappy-0.18.tar.gz) = 36d869f3c32c85525ac2be292764da46642236f0361fc200f99bbb11b229cb30
+SIZE (Compress-Snappy-0.18.tar.gz) = 41891
diff --git a/archivers/p5-Compress-Snappy/pkg-descr b/archivers/p5-Compress-Snappy/pkg-descr
new file mode 100644
index 000000000000..9c1018fc9979
--- /dev/null
+++ b/archivers/p5-Compress-Snappy/pkg-descr
@@ -0,0 +1,9 @@
+Compress::Snappy provides an interface to Google's Snappy (de)compressor.
+
+Snappy does not aim for maximum compression, or compatibility with any other
+compression library; instead, it aims for very high speeds and reasonable
+compression. For instance, compared to the fastest mode of zlib, Snappy is an
+order of magnitude faster for most inputs, but the resulting compressed files
+are anywhere from 20% to 100% bigger.
+
+WWW: http://search.cpan.org/dist/Compress-Snappy/
diff --git a/archivers/p5-Compress-Snappy/pkg-plist b/archivers/p5-Compress-Snappy/pkg-plist
new file mode 100644
index 000000000000..40777720435b
--- /dev/null
+++ b/archivers/p5-Compress-Snappy/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Compress/Snappy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/Snappy/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/Snappy/Snappy.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/Snappy/Snappy.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/Snappy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Compress