aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /archivers
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
downloadports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.tar.gz
ports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile4
-rw-r--r--archivers/php56-bz2/Makefile10
-rw-r--r--archivers/php56-phar/Makefile10
-rw-r--r--archivers/php56-phar/files/patch-config.m441
-rw-r--r--archivers/php56-phar/files/patch-phar.c11
-rw-r--r--archivers/php56-zip/Makefile10
-rw-r--r--archivers/php56-zlib/Makefile10
-rw-r--r--archivers/php56-zlib/files/patch-zlib.c10
8 files changed, 106 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index be50eee5c837..7b79596fa88e 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -150,6 +150,10 @@
SUBDIR += php55-phar
SUBDIR += php55-zip
SUBDIR += php55-zlib
+ SUBDIR += php56-bz2
+ SUBDIR += php56-phar
+ SUBDIR += php56-zip
+ SUBDIR += php56-zlib
SUBDIR += pigz
SUBDIR += pixz
SUBDIR += plzip
diff --git a/archivers/php56-bz2/Makefile b/archivers/php56-bz2/Makefile
new file mode 100644
index 000000000000..d65f1696013b
--- /dev/null
+++ b/archivers/php56-bz2/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -bz2
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php56-phar/Makefile b/archivers/php56-phar/Makefile
new file mode 100644
index 000000000000..325bea2c411e
--- /dev/null
+++ b/archivers/php56-phar/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php56-phar/files/patch-config.m4 b/archivers/php56-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1a981bfefdc1
--- /dev/null
+++ b/archivers/php56-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2011-11-25 15:31:20.000000000 +0100
++++ config.m4 2011-11-25 15:47:45.000000000 +0100
+@@ -4,8 +4,38 @@
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php56-phar/files/patch-phar.c b/archivers/php56-phar/files/patch-phar.c
new file mode 100644
index 000000000000..231ec40a8423
--- /dev/null
+++ b/archivers/php56-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2011-11-25 15:38:44.000000000 +0100
++++ phar.c 2011-11-25 15:39:01.000000000 +0100
+@@ -3716,7 +3716,7 @@
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL
diff --git a/archivers/php56-zip/Makefile b/archivers/php56-zip/Makefile
new file mode 100644
index 000000000000..cc86586ec95f
--- /dev/null
+++ b/archivers/php56-zip/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -zip
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php56-zlib/Makefile b/archivers/php56-zlib/Makefile
new file mode 100644
index 000000000000..e9ba04011193
--- /dev/null
+++ b/archivers/php56-zlib/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php56-zlib/files/patch-zlib.c b/archivers/php56-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..0e88fee9c5bf
--- /dev/null
+++ b/archivers/php56-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2012-07-09 15:25:31.000000000 +0200
++++ zlib.c 2012-07-09 15:26:07.000000000 +0200
+@@ -957,6 +957,7 @@
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+
+ php_zlib_output_compression_start(TSRMLS_C);