aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-27 12:10:37 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-27 12:10:37 +0000
commit701ab6a48be35a823b6a34cb1fed31071c39ce09 (patch)
tree77d5ff304429710c629373762ccbefb899092e1f /archivers
parentd3717695d984365bff5d9280bf3d44c7b84fbf6e (diff)
downloadports-701ab6a48be35a823b6a34cb1fed31071c39ce09.tar.gz
ports-701ab6a48be35a823b6a34cb1fed31071c39ce09.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/fastjar/Makefile6
-rw-r--r--archivers/fastjar/pkg-plist5
-rw-r--r--archivers/macutils/Makefile1
-rw-r--r--archivers/stuffit/Makefile5
-rw-r--r--archivers/stuffit/pkg-plist2
-rw-r--r--archivers/ucl/Makefile8
-rw-r--r--archivers/ucl/pkg-plist3
7 files changed, 12 insertions, 18 deletions
diff --git a/archivers/fastjar/Makefile b/archivers/fastjar/Makefile
index fb9168273458..53262ab7040c 100644
--- a/archivers/fastjar/Makefile
+++ b/archivers/fastjar/Makefile
@@ -18,11 +18,13 @@ COMMENT= A version of JDK's `jar' command written entirely in C
GNU_CONFIGURE= yes
USE_GMAKE= yes
+PORTDOCS= CHANGES README
+PLIST_FILES= bin/fastjar bin/grepjar
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/fastjar
- cd ${WRKSRC} && ${INSTALL_DATA} CHANGES README ${PREFIX}/share/doc/fastjar/
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/archivers/fastjar/pkg-plist b/archivers/fastjar/pkg-plist
deleted file mode 100644
index 82f4dcb1ebf0..000000000000
--- a/archivers/fastjar/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/fastjar
-bin/grepjar
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/archivers/macutils/Makefile b/archivers/macutils/Makefile
index 44172bede62b..ec9e7fb44562 100644
--- a/archivers/macutils/Makefile
+++ b/archivers/macutils/Makefile
@@ -22,7 +22,6 @@ MAN1= macunpack.1 hexbin.1 macsave.1 macstream.1 binhex.1 tomac.1 \
frommac.1 macutil.1
BINDIR= ${PREFIX}/bin
-DOCDIR= ${PREFIX}/share/doc/macutils
DOCFILES= README.crc README.hexbin README.macput README.unpit \
README.zoom README.crc.orig README.macget README.scan \
README.unsit ../README
diff --git a/archivers/stuffit/Makefile b/archivers/stuffit/Makefile
index 8d2f9669c56c..9c8e55df213d 100644
--- a/archivers/stuffit/Makefile
+++ b/archivers/stuffit/Makefile
@@ -29,6 +29,7 @@ STRIP= # empty: do not strip linux binary during INSTALL_PROGRAM
WRKSRC= ${WRKDIR}
STUFFIT_FILES= bin/unstuff bin/stuff
STUFFIT_MAN= man/man1/stuff.1 man/man1/unstuff.1
+PLIST_FILES= ${STUFFIT_FILES}
MAN1= stuff.1 unstuff.1
@@ -38,10 +39,10 @@ post-fetch:
do-install:
.for sFile in ${STUFFIT_FILES}
${INSTALL_PROGRAM} ${WRKSRC}/${sFile} ${PREFIX}/bin
- brandelf -t Linux ${PREFIX}/${sFile}
+ ${BRANDELF} -t Linux ${PREFIX}/${sFile}
.endfor
.for mFile in ${STUFFIT_MAN}
- ${INSTALL_MAN} ${WRKSRC}/${mFile} ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${mFile} ${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>
diff --git a/archivers/stuffit/pkg-plist b/archivers/stuffit/pkg-plist
deleted file mode 100644
index 52472bdefcf5..000000000000
--- a/archivers/stuffit/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/stuff
-bin/unstuff
diff --git a/archivers/ucl/Makefile b/archivers/ucl/Makefile
index d247459a6967..803dd5f250df 100644
--- a/archivers/ucl/Makefile
+++ b/archivers/ucl/Makefile
@@ -17,13 +17,15 @@ INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --enable-shared
+PORTDOCS= COPYING README
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/examples/.libs/uclpack \
${PREFIX}/bin/uclpack
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
-.for file in COPYING README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/${PORTNAME}
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/archivers/ucl/pkg-plist b/archivers/ucl/pkg-plist
index 743e62b8a848..47aaf53ed07f 100644
--- a/archivers/ucl/pkg-plist
+++ b/archivers/ucl/pkg-plist
@@ -5,7 +5,4 @@ include/ucl/uclconf.h
lib/libucl.a
lib/libucl.so
lib/libucl.so.1
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/ucl