aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-09-14 13:32:06 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-09-14 13:32:06 +0000
commit4fe6852b8fc27fae11fdc1a2e6a04519dff79d2d (patch)
tree3c0e8bfe673a5c1e30efc1a8f7c2fa62a73243fc /archivers
parentaa0a6b33abb64a760dac34854c5336e9dd14e0c3 (diff)
downloadports-4fe6852b8fc27fae11fdc1a2e6a04519dff79d2d.tar.gz
ports-4fe6852b8fc27fae11fdc1a2e6a04519dff79d2d.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/bzip2/Makefile4
-rw-r--r--archivers/unzip/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index c1928f39c43f..04d2fe27dbe7 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -27,6 +27,10 @@ MLINKS= bzip2.1 bunzip2.1 bzip2.1 bzcat.1 bzip2.1 bz2cat.1 \
bzgrep.1 bzfgrep.1 \
bzmore.1 bzless.1
+.ifdef USE_BZIP2
+.error You have `USE_BZIP2' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bzip2 ${PREFIX}/bin
${LN} -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bunzip2
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 767294ce728c..dcbd2ce1a7d7 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -25,6 +25,10 @@ EXTRACT_ONLY= ${PORTNAME}550.tar.gz
MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK -DUSE_SMITH_CODE"
.endif
+.ifdef USE_UNZIP
+.error You have `USE_UNZIP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"