aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-02-06 17:47:51 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-02-06 17:47:51 +0000
commit54345369c0762b148bf8185c039119fece58866c (patch)
tree18c74f93c389a20b24b919be352013e85d8ea3a2 /archivers
parentab635f152ef10f63cf39e1a728ef49e59bc8f815 (diff)
downloadports-54345369c0762b148bf8185c039119fece58866c.tar.gz
ports-54345369c0762b148bf8185c039119fece58866c.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/rpm4/Makefile4
-rw-r--r--archivers/rpm4/distinfo4
-rw-r--r--archivers/rpm4/files/patch-lib_backend_db3.c9
-rw-r--r--archivers/rpm4/files/patch-misc_glob.c14
-rw-r--r--archivers/rpm4/files/patch-misc_glob.h18
-rw-r--r--archivers/rpm4/pkg-plist21
6 files changed, 11 insertions, 59 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 83d207752804..cc46fcf981f2 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= rpm
-PORTVERSION= 4.10.2
+PORTVERSION= 4.11.0.1
CATEGORIES= archivers
-MASTER_SITES= http://rpm.org/releases/rpm-${PORTVERSION:R}.x/ \
+MASTER_SITES= http://rpm.org/releases/rpm-${PORTVERSION:R:R}.x/ \
ftp://ftp.mirrorservice.org/sites/ftp.rpm.org/pub/rpm/dist/rpm-${PORTVERSION:E}.x/
MAINTAINER= johans@FreeBSD.org
diff --git a/archivers/rpm4/distinfo b/archivers/rpm4/distinfo
index d218d3e25925..37ef09b1389e 100644
--- a/archivers/rpm4/distinfo
+++ b/archivers/rpm4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rpm-4.10.2.tar.bz2) = e9278a2b40f08bae5a9592b9b42f11f88b2e880cc34e57113d53461ed7de6e7b
-SIZE (rpm-4.10.2.tar.bz2) = 3545536
+SHA256 (rpm-4.11.0.1.tar.bz2) = 98496c0c73095d7c66a8b6f1d8ab00998e1daf4e46a017ae74190c65132ffb21
+SIZE (rpm-4.11.0.1.tar.bz2) = 3670158
diff --git a/archivers/rpm4/files/patch-lib_backend_db3.c b/archivers/rpm4/files/patch-lib_backend_db3.c
index 829bc2a4dba6..6310322cbfd9 100644
--- a/archivers/rpm4/files/patch-lib_backend_db3.c
+++ b/archivers/rpm4/files/patch-lib_backend_db3.c
@@ -9,12 +9,3 @@
#include <rpm/rpmtypes.h>
#include <rpm/rpmmacro.h>
-@@ -213,7 +215,7 @@ errxit:
-
- void dbSetFSync(void *dbenv, int enable)
- {
-- db_env_set_func_fsync(enable ? fdatasync : fsync_disable);
-+ db_env_set_func_fsync(enable ? fsync : fsync_disable);
- }
-
- int dbiSync(dbiIndex dbi, unsigned int flags)
diff --git a/archivers/rpm4/files/patch-misc_glob.c b/archivers/rpm4/files/patch-misc_glob.c
deleted file mode 100644
index 9a06b324faf6..000000000000
--- a/archivers/rpm4/files/patch-misc_glob.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- misc/glob.c.orig 2010-12-03 13:11:57.000000000 +0100
-+++ misc/glob.c 2011-03-03 19:12:51.000000000 +0100
-@@ -907,6 +907,11 @@ prefix_array (const char *dirname, char
- return 0;
- }
-
-+int
-+glob_pattern_p (const char *pattern, int quote)
-+{
-+ return __glob_pattern_p(pattern, quote);
-+}
-
- /* We must not compile this function twice. */
- #if !defined _LIBC || !defined NO_GLOB_PATTERN_P
diff --git a/archivers/rpm4/files/patch-misc_glob.h b/archivers/rpm4/files/patch-misc_glob.h
deleted file mode 100644
index 6d8b056c8d48..000000000000
--- a/archivers/rpm4/files/patch-misc_glob.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- misc/glob.h.orig 2011-11-14 22:06:03.000000000 +0100
-+++ misc/glob.h 2011-11-14 22:07:01.000000000 +0100
-@@ -110,10 +110,11 @@
- #endif
- typedef struct
- {
-- __size_t gl_pathc; /* Count of paths matched by the pattern. */
-- char **gl_pathv; /* List of matched pathnames. */
-- __size_t gl_offs; /* Slots to reserve in `gl_pathv'. */
-- int gl_flags; /* Set to FLAGS, maybe | GLOB_MAGCHAR. */
-+ __size_t gl_pathc; /* Count of total paths so far. */
-+ __size_t gl_matchc; /* Count of paths matching pattern. */
-+ __size_t gl_offs; /* Reserved at beginning of gl_pathv. */
-+ int gl_flags; /* Copy of flags parameter to glob. */
-+ char **gl_pathv; /* List of paths matching pattern. */
-
- /* If the GLOB_ALTDIRFUNC flag is set, the following functions
- are used instead of the normal file access functions. */
diff --git a/archivers/rpm4/pkg-plist b/archivers/rpm4/pkg-plist
index ed7f5e954637..5770c65ae97a 100644
--- a/archivers/rpm4/pkg-plist
+++ b/archivers/rpm4/pkg-plist
@@ -33,6 +33,7 @@ include/rpm/rpmlegacy.h
include/rpm/rpmpol.h
include/rpm/rpmps.h
include/rpm/rpmprob.h
+include/rpm/rpmstrpool.h
include/rpm/rpmtag.h
include/rpm/rpmtd.h
include/rpm/rpmte.h
@@ -46,19 +47,19 @@ include/rpm/rpmspec.h
lib/librpm.a
lib/librpm.la
lib/librpm.so
-lib/librpm.so.3
+lib/librpm.so.4
lib/librpmbuild.a
lib/librpmbuild.la
lib/librpmbuild.so
-lib/librpmbuild.so.3
+lib/librpmbuild.so.4
lib/librpmio.a
lib/librpmio.la
lib/librpmio.so
-lib/librpmio.so.3
+lib/librpmio.so.4
lib/librpmsign.a
lib/librpmsign.la
lib/librpmsign.so
-lib/librpmsign.so.1
+lib/librpmsign.so.2
lib/rpm/rpm.daily
lib/rpm/rpm.log
lib/rpm/macros.perl
@@ -167,12 +168,9 @@ lib/rpm/platform/sh4-freebsd/macros
lib/rpm/platform/sh4a-freebsd/macros
lib/rpm-plugins/exec.so
lib/rpm-plugins/exec.la
-lib/rpm-plugins/sepolicy.so
-lib/rpm-plugins/sepolicy.la
-%%NLS%%share/locale/bn_IN/LC_MESSAGES/rpm.mo
+%%NLS%%share/locale/br/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/ca/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/cs/LC_MESSAGES/rpm.mo
-%%NLS%%share/locale/cs_CZ/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/da/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/de/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/el/LC_MESSAGES/rpm.mo
@@ -180,8 +178,6 @@ lib/rpm-plugins/sepolicy.la
%%NLS%%share/locale/es/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/fi/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/fr/LC_MESSAGES/rpm.mo
-%%NLS%%share/locale/gu/LC_MESSAGES/rpm.mo
-%%NLS%%share/locale/id/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/is/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/it/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/ja/LC_MESSAGES/rpm.mo
@@ -200,6 +196,7 @@ lib/rpm-plugins/sepolicy.la
%%NLS%%share/locale/sv/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/te/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/tr/LC_MESSAGES/rpm.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/rpm.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/rpm.mo
%%PYTHON%%%%PYTHON_SITELIBDIR%%/rpm/__init__.py
@@ -289,10 +286,6 @@ libdata/pkgconfig/rpm.pc
@dirrmtry src
%%NLS%%@dirrmtry share/locale/sr@latin/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/sr@latin
-%%NLS%%@dirrmtry share/locale/bn_IN/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/bn_IN
-%%NLS%%@dirrmtry share/locale/cs_CZ/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/cs_CZ
%%NLS%%@dirrmtry share/locale/te/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/te
%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/rpm