aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-11-07 15:22:49 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-11-07 15:22:49 +0000
commit649f272e67f614b6b6a3118b75f92217c814f2f4 (patch)
tree055b06350e8199301ba8ca2182a3f149cbf79a5e /archivers
parent196ab78cdbd08800c7ecd88399827b4d9fd1d5e9 (diff)
downloadports-649f272e67f614b6b6a3118b75f92217c814f2f4.tar.gz
ports-649f272e67f614b6b6a3118b75f92217c814f2f4.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libunrar/Makefile1
-rw-r--r--archivers/libunrar/files/patch-makefile.unix9
2 files changed, 6 insertions, 4 deletions
diff --git a/archivers/libunrar/Makefile b/archivers/libunrar/Makefile
index 87b608b39da9..115259eef243 100644
--- a/archivers/libunrar/Makefile
+++ b/archivers/libunrar/Makefile
@@ -22,6 +22,7 @@ WRKSRC= ${WRKDIR}/unrar
USE_GMAKE= yes
MAKEFILE= makefile.unix
+MAKE_ENV+= CXX="${CXX}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= lib
INSTALLS_SHLIB= yes
diff --git a/archivers/libunrar/files/patch-makefile.unix b/archivers/libunrar/files/patch-makefile.unix
index 60649ebfb41a..4c5aced77d80 100644
--- a/archivers/libunrar/files/patch-makefile.unix
+++ b/archivers/libunrar/files/patch-makefile.unix
@@ -1,9 +1,10 @@
--- makefile.unix.orig Sat Apr 30 04:00:12 2005
+++ makefile.unix Fri Sep 23 16:22:04 2005
-@@ -7,9 +7,10 @@
+@@ -6,10 +6,10 @@
+ #
# Linux using GCC
- CXX=g++
+-CXX=g++
-CXXFLAGS=-O2
-DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+CXXFLAGS=$(CFLAGS) -fPIC -DPIC
@@ -13,7 +14,7 @@
# Linux using LCC
#CXX=lcc
-@@ -86,7 +87,7 @@
+@@ -86,7 +86,7 @@
LINK=$(CXX)
UNRAR_OBJ=filestr.o recvol.o rs.o scantree.o
@@ -22,7 +23,7 @@
OBJECTS=rar.o strlist.o strfn.o pathfn.o int64.o savepos.o global.o file.o filefn.o filcreat.o \
archive.o arcread.o unicode.o system.o isnt.o crypt.o crc.o rawread.o encname.o \
-@@ -114,6 +115,12 @@
+@@ -114,6 +114,12 @@
$(STRIP) default.sfx
lib: WHAT=RARDLL