aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2008-06-19 22:06:13 +0000
committerErwin Lansing <erwin@FreeBSD.org>2008-06-19 22:06:13 +0000
commit8b0ba84c09fcd353eea2521cd6ca8e57f82eb781 (patch)
treea21f23109e2dc7d292a967eb6050bba8bfccd7df /archivers
parent54a151c57f683fe85dd05d018e3221f8ede2f308 (diff)
downloadports-8b0ba84c09fcd353eea2521cd6ca8e57f82eb781.tar.gz
ports-8b0ba84c09fcd353eea2521cd6ca8e57f82eb781.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-librtfcomp/Makefile28
-rw-r--r--archivers/py-librtfcomp/pkg-plist3
3 files changed, 32 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index c9b3c42c7ba8..5abdab0c899b 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -117,6 +117,7 @@
SUBDIR += ppmd
SUBDIR += ppmd-7z
SUBDIR += ppunpack
+ SUBDIR += py-librtfcomp
SUBDIR += py-lzma
SUBDIR += py-tarfile
SUBDIR += rar
diff --git a/archivers/py-librtfcomp/Makefile b/archivers/py-librtfcomp/Makefile
new file mode 100644
index 000000000000..f589cf85d99f
--- /dev/null
+++ b/archivers/py-librtfcomp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-librtfcomp
+# Date Created: 13 June 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Python bindings for the LZRTF compression library
+
+LIB_DEPENDS= rtfcomp.0:${PORTSDIR}/archivers/librtfcomp
+BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../librtfcomp
+
+USE_PYTHON= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+
+RTFCOMP_SLAVE= pythonb
+
+do-install:
+ @(cd ${WRKSRC}/python && ${MAKE} install)
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/py-librtfcomp/pkg-plist b/archivers/py-librtfcomp/pkg-plist
new file mode 100644
index 000000000000..cd3d527a0d95
--- /dev/null
+++ b/archivers/py-librtfcomp/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/pyrtfcomp.a
+%%PYTHON_SITELIBDIR%%/pyrtfcomp.la
+%%PYTHON_SITELIBDIR%%/pyrtfcomp.so