aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 09:32:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 12:45:56 +0000
commit33ff8541ea695ecc76fd38cc115db4c59e5043e7 (patch)
treea9c5bb4af1331b0277fb12ac128210f3f2106fb2 /archivers
parentcc5f7dfb62b2c08631ffec57b4eca5eea5df963b (diff)
downloadports-33ff8541ea695ecc76fd38cc115db4c59e5043e7.tar.gz
ports-33ff8541ea695ecc76fd38cc115db4c59e5043e7.zip
archivers/unrar: Update to 6.10
- Remove my LOCAL from MASTER_SITES
Diffstat (limited to 'archivers')
-rw-r--r--archivers/unrar/Makefile7
-rw-r--r--archivers/unrar/distinfo6
-rw-r--r--archivers/unrar/files/patch-os.hpp4
-rw-r--r--archivers/unrar/files/patch-rijndael.cpp28
-rw-r--r--archivers/unrar/files/patch-rijndael.hpp6
5 files changed, 25 insertions, 26 deletions
diff --git a/archivers/unrar/Makefile b/archivers/unrar/Makefile
index 6a40b3cf9032..555fdec77d84 100644
--- a/archivers/unrar/Makefile
+++ b/archivers/unrar/Makefile
@@ -1,12 +1,11 @@
# Created by: ache
PORTNAME= unrar
-PORTVERSION= 6.02
+PORTVERSION= 6.10
PORTEPOCH= 6
CATEGORIES+= archivers
-MASTER_SITES= https://rarlab.com/rar/ \
- LOCAL/sunpoet
-DISTNAME= unrarsrc-6.0.7
+MASTER_SITES= https://rarlab.com/rar/
+DISTNAME= unrarsrc-6.1.4
MAINTAINER?= sunpoet@FreeBSD.org
COMMENT= Extract, view & test RAR archives
diff --git a/archivers/unrar/distinfo b/archivers/unrar/distinfo
index b297eb825a48..3dfcf9659c83 100644
--- a/archivers/unrar/distinfo
+++ b/archivers/unrar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1623697046
-SHA256 (unrarsrc-6.0.7.tar.gz) = a7029942006cbcced3f3b7322ec197683f8e7be408972ca08099b196c038f518
-SIZE (unrarsrc-6.0.7.tar.gz) = 232903
+TIMESTAMP = 1643970970
+SHA256 (unrarsrc-6.1.4.tar.gz) = c0ed58629243961c3f1ec90c08b11ff93261e568dbfdce2bf3b759ee7a4a3b7c
+SIZE (unrarsrc-6.1.4.tar.gz) = 235483
diff --git a/archivers/unrar/files/patch-os.hpp b/archivers/unrar/files/patch-os.hpp
index 6e1ef0d20b34..c0a0c1604907 100644
--- a/archivers/unrar/files/patch-os.hpp
+++ b/archivers/unrar/files/patch-os.hpp
@@ -1,6 +1,6 @@
---- os.hpp.orig 2019-04-27 20:05:18 UTC
+--- os.hpp.orig 2022-01-24 07:33:18 UTC
+++ os.hpp
-@@ -166,6 +166,10 @@
+@@ -168,6 +168,10 @@
#include <locale.h>
diff --git a/archivers/unrar/files/patch-rijndael.cpp b/archivers/unrar/files/patch-rijndael.cpp
index 2656ded5d19e..19749b3b7403 100644
--- a/archivers/unrar/files/patch-rijndael.cpp
+++ b/archivers/unrar/files/patch-rijndael.cpp
@@ -1,7 +1,7 @@
---- rijndael.cpp.orig 2019-04-27 20:05:20 UTC
+--- rijndael.cpp.orig 2022-01-24 07:33:18 UTC
+++ rijndael.cpp
-@@ -7,6 +7,8 @@
- ***************************************************************************/
+@@ -3,6 +3,8 @@
+ **************************************************************************/
#include "rar.hpp"
+#ifndef OPENSSL_AES
@@ -9,7 +9,7 @@
#ifdef USE_SSE
#include <wmmintrin.h>
#endif
-@@ -56,6 +58,7 @@ inline void Copy128(byte *dest,const byt
+@@ -75,6 +77,7 @@ inline void Copy128(byte *dest,const byte *src)
#endif
}
@@ -17,12 +17,12 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// API
-@@ -63,14 +66,41 @@ inline void Copy128(byte *dest,const byt
+@@ -82,14 +85,41 @@ inline void Copy128(byte *dest,const byte *src)
Rijndael::Rijndael()
{
+#ifndef OPENSSL_AES
- if (S[0]==0)
+ if (S5[0]==0)
GenerateTables();
+#endif // OPENSSL_AES
CBCMode = true; // Always true for RAR.
@@ -59,7 +59,7 @@
#ifdef USE_SSE
// Check SSE here instead of constructor, so if object is a part of some
// structure memset'ed before use, this variable is not lost.
-@@ -114,6 +144,7 @@ void Rijndael::Init(bool Encrypt,const b
+@@ -139,6 +169,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
if(!Encrypt)
keyEncToDec();
@@ -67,7 +67,7 @@
}
void Rijndael::blockEncrypt(const byte *input,size_t inputLen,byte *outBuffer)
-@@ -121,6 +152,15 @@ void Rijndael::blockEncrypt(const byte *
+@@ -146,6 +177,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
if (inputLen <= 0)
return;
@@ -83,7 +83,7 @@
size_t numBlocks = inputLen/16;
#ifdef USE_SSE
if (AES_NI)
-@@ -179,6 +219,7 @@ void Rijndael::blockEncrypt(const byte *
+@@ -204,6 +244,7 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
input += 16;
}
Copy128(m_initVector,prevBlock);
@@ -91,7 +91,7 @@
}
-@@ -220,6 +261,15 @@ void Rijndael::blockDecrypt(const byte *
+@@ -245,6 +286,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
if (inputLen <= 0)
return;
@@ -107,7 +107,7 @@
size_t numBlocks=inputLen/16;
#ifdef USE_SSE
if (AES_NI)
-@@ -282,6 +332,8 @@ void Rijndael::blockDecrypt(const byte *
+@@ -307,6 +357,8 @@ void Rijndael::blockDecrypt(const byte *input, size_t
}
memcpy(m_initVector,iv,16);
@@ -116,7 +116,7 @@
}
-@@ -317,7 +369,7 @@ void Rijndael::blockDecryptSSE(const byt
+@@ -342,7 +394,7 @@ void Rijndael::blockDecryptSSE(const byte *input, size
}
#endif
@@ -125,8 +125,8 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// ALGORITHM
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -457,7 +509,7 @@ void Rijndael::GenerateTables()
- U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[i][0]=T6[i][1]=T7[i][2]=T8[i][3]=FFmul0e(b);
+@@ -471,7 +523,7 @@ void Rijndael::GenerateTables()
+ U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[I][0]=T6[I][1]=T7[I][2]=T8[I][3]=gmul(b,0xe);
}
}
-
diff --git a/archivers/unrar/files/patch-rijndael.hpp b/archivers/unrar/files/patch-rijndael.hpp
index e85656700db5..3c375833ef8e 100644
--- a/archivers/unrar/files/patch-rijndael.hpp
+++ b/archivers/unrar/files/patch-rijndael.hpp
@@ -1,6 +1,6 @@
---- rijndael.hpp.orig 2018-06-24 15:10:31 UTC
+--- rijndael.hpp.orig 2022-01-24 07:33:18 UTC
+++ rijndael.hpp
-@@ -16,6 +16,13 @@
+@@ -12,6 +12,13 @@
class Rijndael
{
private:
@@ -14,7 +14,7 @@
#ifdef USE_SSE
void blockEncryptSSE(const byte *input,size_t numBlocks,byte *outBuffer);
void blockDecryptSSE(const byte *input, size_t numBlocks, byte *outBuffer);
-@@ -25,6 +32,7 @@ class Rijndael
+@@ -21,6 +28,7 @@ class Rijndael
void keySched(byte key[_MAX_KEY_COLUMNS][4]);
void keyEncToDec();
void GenerateTables();