aboutsummaryrefslogtreecommitdiff
path: root/astro/SETIsupport
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 06:38:49 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 06:38:49 +0000
commit0766aae806366955ca26568d8a4fc704885d8583 (patch)
tree5ca8519cd15a1f463f07c339907fff5039b4ddb5 /astro/SETIsupport
parent56377787c199f05ebaf2618258c26c191c30a94b (diff)
downloadports-0766aae806366955ca26568d8a4fc704885d8583.tar.gz
ports-0766aae806366955ca26568d8a4fc704885d8583.zip
Notes
Diffstat (limited to 'astro/SETIsupport')
-rw-r--r--astro/SETIsupport/Makefile32
-rw-r--r--astro/SETIsupport/distinfo1
-rw-r--r--astro/SETIsupport/files/SETISupport.sh11
-rw-r--r--astro/SETIsupport/pkg-comment1
-rw-r--r--astro/SETIsupport/pkg-descr6
-rw-r--r--astro/SETIsupport/pkg-message14
-rw-r--r--astro/SETIsupport/pkg-plist3
7 files changed, 68 insertions, 0 deletions
diff --git a/astro/SETIsupport/Makefile b/astro/SETIsupport/Makefile
new file mode 100644
index 000000000000..a855c4d04f8c
--- /dev/null
+++ b/astro/SETIsupport/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: SETISupport
+# Date Created: 1 Jul 2000
+# Whom: HIYAMA Takeshi <th@cis.ibaraki.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SETISupport
+PORTVERSION= 0.74
+CATEGORIES= astro java
+MASTER_SITES= http://members5.cool.ne.jp/%7Egrgr56/SETITest/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= th@cis.ibaraki.ac.jp
+
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
+ ${LOCALBASE}/etc/javavms:${PORTSDIR}/java/jre \
+ setiathome:${PORTSDIR}/astro/setiathome
+
+USE_XLIB= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/java/SETISupport
+ @${INSTALL_DATA} ${DISTDIR}/SETISupport.jar ${PREFIX}/share/java/SETISupport
+ @${INSTALL_SCRIPT} ${FILESDIR}/SETISupport.sh ${PREFIX}/bin/SETISupport
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/astro/SETIsupport/distinfo b/astro/SETIsupport/distinfo
new file mode 100644
index 000000000000..38fbda0aa348
--- /dev/null
+++ b/astro/SETIsupport/distinfo
@@ -0,0 +1 @@
+MD5 (SETISupport.jar) = cdab7d21a0f597fa34deb3da2d3ebb88
diff --git a/astro/SETIsupport/files/SETISupport.sh b/astro/SETIsupport/files/SETISupport.sh
new file mode 100644
index 000000000000..4437ba596682
--- /dev/null
+++ b/astro/SETIsupport/files/SETISupport.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+#
+
+CLASSPATH=${CLASSPATH}:/usr/local/share/java/SETISupport/SETISupport.jar
+export CLASSPATH
+
+if [ ! -d ${SETISUPPORT_WRKDIR:=${HOME}/.SETISupport} ]; then
+ mkdir ${SETISUPPORT_WRKDIR}
+fi
+cd ${SETISUPPORT_WRKDIR}
+exec /usr/local/bin/javavm SETISupport $@
diff --git a/astro/SETIsupport/pkg-comment b/astro/SETIsupport/pkg-comment
new file mode 100644
index 000000000000..fb07e08d093c
--- /dev/null
+++ b/astro/SETIsupport/pkg-comment
@@ -0,0 +1 @@
+JAVA application that shows current state of seti@home client
diff --git a/astro/SETIsupport/pkg-descr b/astro/SETIsupport/pkg-descr
new file mode 100644
index 000000000000..60e60df234cb
--- /dev/null
+++ b/astro/SETIsupport/pkg-descr
@@ -0,0 +1,6 @@
+This is a JAVA application that shows the current state
+of you're seti@home client graphically.
+It will show the details of data currently analyzing,
+and which direction the data came from.
+
+WWW: http://member.nifty.ne.jp/GOtsubo/contents/SETISupport/edownload.html
diff --git a/astro/SETIsupport/pkg-message b/astro/SETIsupport/pkg-message
new file mode 100644
index 000000000000..806baf78acd8
--- /dev/null
+++ b/astro/SETIsupport/pkg-message
@@ -0,0 +1,14 @@
+It will create a working directory ${HOME}/.SETISupport
+If you don't like this working directory,
+please set environment variable "SETISUPPORT_WRKDIR" to the directory you like.
+
+For Example, if you want working directory to be /var/db/setiathome ,
+ setenv SETISUPPORT_WRKDIR /var/db/setiathome
+ for csh or tcsh
+ export SETISUPPORT_WRKDIR=/var/db/setiathome
+ for sh or bash
+
+Maybe you want set this to the working directory setiathome,
+but don't forget that you need write permission for working directory.
+If you installed setiathome from ports or package,
+setiathome's working directory is owned by nobody.
diff --git a/astro/SETIsupport/pkg-plist b/astro/SETIsupport/pkg-plist
new file mode 100644
index 000000000000..63c1b0e4bd8b
--- /dev/null
+++ b/astro/SETIsupport/pkg-plist
@@ -0,0 +1,3 @@
+bin/SETISupport
+share/java/SETISupport/SETISupport.jar
+@dirrm share/java/SETISupport