aboutsummaryrefslogtreecommitdiff
path: root/astro/aa
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-07 20:48:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-07 20:48:47 +0000
commitdd69ee67a005e10de635ec55f97c02441a913d01 (patch)
tree6572fda426555d0780ee96eb89dc6cc2285d1dbf /astro/aa
parentf634e89e0bd3074868ed81f5bd81a96be2cfce5e (diff)
downloadports-dd69ee67a005e10de635ec55f97c02441a913d01.tar.gz
ports-dd69ee67a005e10de635ec55f97c02441a913d01.zip
Notes
Diffstat (limited to 'astro/aa')
-rw-r--r--astro/aa/Makefile10
-rw-r--r--astro/aa/distinfo6
-rw-r--r--astro/aa/files/patch-gplan.c54
-rw-r--r--astro/aa/files/patch-kfiles.c21
-rw-r--r--astro/aa/pkg-descr2
5 files changed, 85 insertions, 8 deletions
diff --git a/astro/aa/Makefile b/astro/aa/Makefile
index 94828c18d240..ceca4e0ff0b7 100644
--- a/astro/aa/Makefile
+++ b/astro/aa/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aa
PORTVERSION= 56
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://moshier.net/ \
http://www.mirrorservice.org/sites/www.moshier.net/
@@ -24,15 +25,22 @@ ALL_TARGET= aa
SUB_FILES= pkg-message
PORTDOCS= read.me readme.404 Readme.FreeBSD
+PORTDATA= messier.cat orbit.cat star.cat
PLIST_FILES= bin/aa etc/aa.ini.default
post-patch:
- @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/kfiles.c
+ @${REINPLACE_CMD} \
+ 's|%%PREFIX%%|${PREFIX}|g ; s|%%DATADIR%%|${DATADIR}|g' \
+ ${WRKSRC}/kfiles.c
@${REINPLACE_CMD} 's|CFLAGS= -O2|CFLAGS+=|' ${WRKSRC}/makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/aa ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/aa.ini ${PREFIX}/etc/aa.ini.default
+ @${MKDIR} ${DATADIR}
+.for i in ${PORTDATA}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DATADIR}
+.endfor
post-install:
.if !defined(NOPORTDOCS)
diff --git a/astro/aa/distinfo b/astro/aa/distinfo
index bc7ca8d5652a..b4c7d36dfabf 100644
--- a/astro/aa/distinfo
+++ b/astro/aa/distinfo
@@ -1,3 +1,3 @@
-MD5 (aa-56.zip) = 74dfb091d8a749e6583bfc2880aecd10
-SHA256 (aa-56.zip) = c7b1a3d2bcf46b7e649fbe7858725f80be153668cbb8ce51d9f39ee4567c262b
-SIZE (aa-56.zip) = 415059
+MD5 (aa-56.zip) = 39c5e66a0650b17e405266fd3ed603ca
+SHA256 (aa-56.zip) = 6ecd9d84ab5022b8952d7f1a88d1f7e9f05109b1d5c27abe2866f2494ff3f861
+SIZE (aa-56.zip) = 415444
diff --git a/astro/aa/files/patch-gplan.c b/astro/aa/files/patch-gplan.c
new file mode 100644
index 000000000000..5738cfb37b8f
--- /dev/null
+++ b/astro/aa/files/patch-gplan.c
@@ -0,0 +1,54 @@
+--- gplan.c.orig 2003-11-27 02:37:42.000000000 +0100
++++ gplan.c 2008-02-29 19:00:02.000000000 +0100
+@@ -83,12 +83,8 @@
+ /* VAX CC rejects "signed char." */
+ char *p;
+ #else
+-#ifdef __STDC__
+- signed char *p;
+-#else
+ char *p;
+ #endif
+-#endif
+ double *pl, *pb, *pr;
+ #endif
+
+@@ -441,12 +437,8 @@
+ /* VAX CC rejects "signed char." */
+ char *p;
+ #else
+-#ifdef __STDC__
+- signed char *p;
+-#else
+ char *p;
+ #endif
+-#endif
+ long *pl, *pb, *pr;
+ #endif
+ double su, cu, sv, cv;
+@@ -613,12 +605,8 @@
+ /* VAX CC rejects "signed char." */
+ char *p;
+ #else
+-#ifdef __STDC__
+- signed char *p;
+-#else
+ char *p;
+ #endif
+-#endif
+ long *pl, *pr;
+ #endif
+ double su, cu, sv, cv;
+@@ -764,12 +752,8 @@
+ /* VAX CC rejects "signed char." */
+ char *p;
+ #else
+-#ifdef __STDC__
+- signed char *p;
+-#else
+ char *p;
+ #endif
+-#endif
+ long *pl;
+ #endif
+ double su, cu, sv, cv;
diff --git a/astro/aa/files/patch-kfiles.c b/astro/aa/files/patch-kfiles.c
index 6e07341f3f8d..e44f31c70450 100644
--- a/astro/aa/files/patch-kfiles.c
+++ b/astro/aa/files/patch-kfiles.c
@@ -1,16 +1,28 @@
--- kfiles.c.orig Sat Aug 9 17:01:51 2003
-+++ kfiles.c Fri Aug 11 18:51:05 2006
-@@ -3,9 +3,7 @@
++++ kfiles.c Fri Feb 29 16:51:58 2008
+@@ -3,9 +3,8 @@
* or file containing orbital elements.
*/
-#if __BORLANDC__
#include <stdlib.h>
-#endif
++#include <stdio.h>
#include "kep.h"
-@@ -67,13 +65,33 @@
+@@ -26,8 +25,8 @@
+
+ extern char *intfmt, *strfmt;/* see dms.c */
+
+-static char starnam[80] = {'s','t','a','r','.','c','a','t','\0'};
+-static char orbnam[80] = {'o','r','b','i','t','.','c','a','t','\0'};
++static char starnam[80];
++static char orbnam[80];
+ static int linenum = 1;
+
+ /* Read initialization file aa.ini
+@@ -67,13 +66,36 @@
int kinit()
{
double a, b, fl, co, si, u;
@@ -23,6 +35,9 @@
printf( "Planetary and lunar positions approximate DE404.\n" );
-f = fopen( "aa.ini", "r" );
++ snprintf(starnam, 80, "%%DATADIR%%/star.cat");
++ snprintf(orbnam, 80, "%%DATADIR%%/orbit.cat");
++
+/* User inifile */
+ if(home){
+ inifile = strdup(home);
diff --git a/astro/aa/pkg-descr b/astro/aa/pkg-descr
index bfb1295d7c9c..77287c5398b7 100644
--- a/astro/aa/pkg-descr
+++ b/astro/aa/pkg-descr
@@ -5,6 +5,6 @@ extension of modern Lunar theory for the Moon's position. Reads ASCII file
catalogues of stars and orbital elements. Displays all adjustments as it finds
local azimuth and elevation, rise and set times, etc.
-Latest update 2005-11-09.
+Latest update 2006-09-02.
WWW: http://moshier.net/aadoc.html