aboutsummaryrefslogtreecommitdiff
path: root/astro/astrometry/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-17 17:13:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-17 17:13:13 +0000
commit0a64b9e6549eb3a51278578e8045d4bf9589dab3 (patch)
treefd28fce96d1ad19fbb2d3cd159c038c7b8c18d3c /astro/astrometry/Makefile
parent27dfe154062fb9fd9f853d32aa5cfcfd73b23105 (diff)
If you have astronomical imaging of the sky with celestial coordinates you do
not know or do not trust then is for you. Input an image and we'll give you back astrometric calibration meta-data, plus lists of known objects falling inside the field of view.Astrometry.net We have built this astrometric calibration service to create correct, standards-compliant astrometric meta-data for every useful astronomical image ever taken, past and future, in any state of archival disarray. We hope this will help organize, annotate and make searchable all the world's astronomical information. WWW: http://www.astrometry.net/ PR: 136594 Submitted by: Dereckson <dereckson@gmail.com>
Notes
Notes: svn path=/head/; revision=237991
Diffstat (limited to 'astro/astrometry/Makefile')
-rw-r--r--astro/astrometry/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
new file mode 100644
index 000000000000..16527552da1a
--- /dev/null
+++ b/astro/astrometry/Makefile
@@ -0,0 +1,38 @@
+
+# New ports collection makefile for: astrometry
+# Date created: 7 July 2009
+# Whom: Dereckson <dereckson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= astrometry
+PORTVERSION= 0.25
+CATEGORIES= astro
+MASTER_SITES= http://www.astrometry.net/downloads/
+DISTNAME= astrometry.net-${PORTVERSION}
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Describes an astronomical image
+
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ netpbm.1:${PORTSDIR}/graphics/netpbm
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+
+USE_PYTHON= 2.4+
+USE_GMAKE= yes
+ALL_TARGET= all extra
+MAKE_ENV= INSTALL_DIR=${PREFIX}/astrometry
+MAKE_JOBS_UNSAFE= yes
+SUB_FILES= pkg-message
+
+post-extract:
+ ${CP} ${FILESDIR}/gnu-specific-config.h ${WRKSRC}/util/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>