aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-astropulse/Makefile
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2018-01-14 23:38:11 +0000
committerLarry Rosenman <ler@FreeBSD.org>2018-01-14 23:38:11 +0000
commit3be55871f7b1ed611cc8dad737b33ec23bc9fa92 (patch)
tree06f1fb2778a44fcfb03e7c10c44f340559bb76ba /astro/boinc-astropulse/Makefile
parent20d10694c14f0735b9d591fabed7a2bd475bcf3c (diff)
downloadports-3be55871f7b1ed611cc8dad737b33ec23bc9fa92.tar.gz
ports-3be55871f7b1ed611cc8dad737b33ec23bc9fa92.zip
Notes
Diffstat (limited to 'astro/boinc-astropulse/Makefile')
-rw-r--r--astro/boinc-astropulse/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index cc465e78b947..57e0fa07f04a 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3 \
- ${NONEXISTENT}:astro/boinc-setiathome-v8:patch
+ ${NONEXISTENT}:astro/boinc-setiathome:patch
RUN_DEPENDS= boinc_client:net/boinc-client
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
@@ -26,14 +26,14 @@ USES= autoreconf gmake libtool pkgconfig tar:xz
WRKSRC_SUBDIR= client
CPPFLAGS+= -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lexecinfo
# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
BOINC_CLIENT_USER?= boinc
BOINC_CLIENT_GROUP?= boinc
BOINC_CLIENT_HOME?= /var/db/boinc
-SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-v8 && ${MAKE} -V WRKSRC
+SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome && ${MAKE} -V WRKSRC
CONFIGURE_ENV= BOINCDIR="${NONEXISTENT}" \
BOINC_DIR="${NONEXISTENT}" \
SETI_BOINC_DIR="${SETI_WORK}"