aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-setiathome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-02 21:36:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-02 21:36:51 +0000
commit15974c4cbabd526c1a8b7265a7dd530e4e87478e (patch)
treee6c5e00428f8cd94cf4844be03d03aafe440c42e /astro/boinc-setiathome
parente820243a1dd67996c46872888d54ad383dfe8455 (diff)
downloadports-15974c4cbabd526c1a8b7265a7dd530e4e87478e.tar.gz
ports-15974c4cbabd526c1a8b7265a7dd530e4e87478e.zip
- Update to 20050601
Submitted by: J.R. Oldroyd <jr@opal.com> (maintainer)
Notes
Notes: svn path=/head/; revision=136692
Diffstat (limited to 'astro/boinc-setiathome')
-rw-r--r--astro/boinc-setiathome/Makefile76
-rw-r--r--astro/boinc-setiathome/distinfo4
-rw-r--r--astro/boinc-setiathome/files/app_info.xml.in (renamed from astro/boinc-setiathome/files/app_info.xml)0
-rw-r--r--astro/boinc-setiathome/files/patch-configure.ac13
-rw-r--r--astro/boinc-setiathome/files/pkg-install.in9
-rw-r--r--astro/boinc-setiathome/pkg-install7
-rw-r--r--astro/boinc-setiathome/pkg-plist9
7 files changed, 54 insertions, 64 deletions
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index 457f17b2fcba..7271ec63f669 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -1,34 +1,24 @@
-# New ports collection makefile for: boinc-setiathome
-# Date created: 01 October 2004
-# Whom: J.R. Oldroyd <fbsd@opal.com>
+# New ports collection makefile for: boinc-setiathome
+# Date created: 01 October 2004
+# Whom: J.R. Oldroyd <fbsd@opal.com>
#
# $FreeBSD$
#
PORTNAME= boinc-setiathome
-PORTVERSION= 4.07.20050218
-PORTREVISION= 1
+PORTVERSION= 4.07.20050601
CATEGORIES= astro
MASTER_SITES= http://setiweb.ssl.berkeley.edu/sah/seti_source/nightly/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
-DISTNAME= seti_boinc-client-cvs-2005-02-18
+DISTNAME= seti_boinc-client-cvs-2005-06-01
MAINTAINER= fbsd@opal.com
COMMENT= Setiathome for boinc
.include <bsd.port.pre.mk>
-# Build with "make -DWITHOUT_X11" if you don't want the boincmgr
-# GUI management interface or the "screensaver" status displays
-# from any of the client applications.
-#
-# Defining WITHOUT_X11 removes the dependencies on the X11 libs
-# and the glut and jpeg graphics libs.
-
-# Disable GUI on FreeBSD 4.x until
-# undefined reference to `boinc_init_graphics'
-# is fixed
+# Disable GUI on FreeBSD 4.x due to problems with wxgtk lib
.if ${OSVERSION} < 500000
WITHOUT_X11= yes
.endif
@@ -39,16 +29,21 @@ LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
.if !defined(WITHOUT_X11)
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
glut:${PORTSDIR}/graphics/libglut
-USE_XLIB= yes
.endif
USE_AUTOMAKE_VER= 19
USE_AUTOCONF_VER= 259
USE_AUTOHEADER_VER= 259
USE_LIBTOOL_VER= 15
-
GNU_CONFIGURE= yes
+USE_GMAKE= yes
USE_REINPLACE= yes
+.if !defined(WITHOUT_X11)
+USE_XLIB= yes
+.endif
+
+WRKSRC= ${WRKDIR}/seti_boinc
+
CONFIGURE_ARGS= --disable-server
.if !defined(WITHOUT_X11)
CONFIGURE_ARGS+= --disable-dynamic-graphics
@@ -57,58 +52,43 @@ CONFIGURE_ARGS+= --disable-gui
.endif
CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE} CPPFLAGS=-I${X11BASE}/include CXXFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
MAKE_ENV= LANG=C
-USE_GMAKE= yes
-PKGINSTALL= ${WRKDIR}/pkg-install
-WRKSRC= ${WRKDIR}/seti_boinc
+# these must match settings in ../../net/boinc-client/Makefile
+BOINC_USER= boinc
+BOINC_GROUP= nobody
+BOINC_HOME= /var/db/boinc
-FIND_SETI_BINARY=(cd ${WRKSRC}/client; make -V CLIENT_PROG)
SETI_SITE= setiathome.berkeley.edu
SETI_BINARY= setiathome
-PLIST_SUB= SETI_SITE=${SETI_SITE} BOINC_HOME=${BOINC_HOME}
+PLIST_SUB= SETI_BINARY="${SETI_BINARY}" SETI_SITE=${SETI_SITE} \
+ BOINC_HOME=${BOINC_HOME}
.if !defined(WITHOUT_X11)
PLIST_SUB+= BOINC_GUI=""
.else
PLIST_SUB+= BOINC_GUI="@comment "
.endif
-# these must match settings in ../../net/boinc-client/Makefile
-BOINC_USER= boinc
-BOINC_GROUP= nobody
-BOINC_HOME= /var/db/boinc
+SUB_FILES= app_info.xml pkg-install
+SUB_LIST= SETI_BINARY="${SETI_BINARY}" SETI_SITE="${SETI_SITE}" \
+ BOINC_HOME="${BOINC_HOME}" BOINC_USER="${BOINC_USER}" \
+ BOINC_GROUP="${BOINC_GROUP}"
+
+FIND_SETI_BINARY=(cd ${WRKSRC}/client; make -V CLIENT_PROG)
pre-configure:
${TOUCH} ${WRKSRC}/missing
cd ${WRKSRC}; ${ACLOCAL} -I ${LOCALBASE}/share/libtool${USE_LIBTOOL_VER}/libltdl -I m4
-post-build:
- ${SED} -e "s:%%SETI_BINARY%%:${SETI_BINARY}:g" \
- < ${FILESDIR}/app_info.xml > ${WRKDIR}/app_info.xml
- ${SED} -e "s:%%SETI_SITE%%:${SETI_SITE}:g" \
- -e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" \
- -e "s:%%BOINC_USER%%:${BOINC_USER}:g" \
- -e "s:%%BOINC_GROUP%%:${BOINC_GROUP}:g" \
- < pkg-install > ${WRKDIR}/pkg-install
-
do-install:
+ ${MKDIR} ${BOINC_HOME}/projects/${SETI_SITE}
+ ${INSTALL_DATA} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}` ${PREFIX}/lib/boinc/${SETI_BINARY}
.if !defined(WITHOUT_X11)
#${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}`.so ${PREFIX}/lib/boinc/${SETI_BINARY}.so
.endif
post-install:
- ${MKDIR} ${BOINC_HOME}/projects/${SETI_SITE}
- ${INSTALL_DATA} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
- ${LN} -s ${PREFIX}/lib/boinc/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}
-.if !defined(WITHOUT_X11)
- #${LN} -s ${PREFIX}/lib/boinc/${SETI_BINARY}.so ${BOINC_HOME}/projects/${SETI_SITE}
-.endif
- ${REINPLACE_CMD} \
- -e "s:%%SETI_SITE%%:${SETI_SITE}:g" \
- -e "s:%%SETI_BINARY%%:${SETI_BINARY}:g" \
- -e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" \
- ${TMPPLIST}
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/astro/boinc-setiathome/distinfo b/astro/boinc-setiathome/distinfo
index b25181c351c7..808c3c93b38a 100644
--- a/astro/boinc-setiathome/distinfo
+++ b/astro/boinc-setiathome/distinfo
@@ -1,2 +1,2 @@
-MD5 (seti_boinc-client-cvs-2005-02-18.tar.gz) = 6f4aa7dc0a88f50bc6f7c160fb3150ef
-SIZE (seti_boinc-client-cvs-2005-02-18.tar.gz) = 1462337
+MD5 (seti_boinc-client-cvs-2005-06-01.tar.gz) = e18263dfed195e193fd76fd6f6cdbd01
+SIZE (seti_boinc-client-cvs-2005-06-01.tar.gz) = 1858898
diff --git a/astro/boinc-setiathome/files/app_info.xml b/astro/boinc-setiathome/files/app_info.xml.in
index a9a583a2be45..a9a583a2be45 100644
--- a/astro/boinc-setiathome/files/app_info.xml
+++ b/astro/boinc-setiathome/files/app_info.xml.in
diff --git a/astro/boinc-setiathome/files/patch-configure.ac b/astro/boinc-setiathome/files/patch-configure.ac
index d29d0c7e38b4..2ab530f807f2 100644
--- a/astro/boinc-setiathome/files/patch-configure.ac
+++ b/astro/boinc-setiathome/files/patch-configure.ac
@@ -1,5 +1,5 @@
---- configure.ac.orig Fri Feb 18 03:00:30 2005
-+++ configure.ac Thu Apr 28 10:47:23 2005
+--- configure.ac.orig Thu Apr 28 03:01:09 2005
++++ configure.ac Tue May 3 16:07:32 2005
@@ -154,7 +154,7 @@
AC_CHECK_LIB([jpeg], [jpeg_start_decompress])
SAH_CHECK_SETILIB
@@ -9,3 +9,12 @@
dnl AC_CHECK_LIB([stdc++], [main])
SAH_REQUIRES([boinc],[SAH_CHECK_BOINC],["${no_boinc}" = yes],
+@@ -231,7 +231,7 @@
+ AC_FUNC_STAT
+ AC_FUNC_STRFTIME
+ AC_CHECK_FUNCS([atexit exit _exit floor getcwd memset munmap putenv sqrt \
+-strchr strstr atoll dlopen sincosf sincos sinf cosf atanf])
++strchr strstr atoll dlopen])
+
+ if test "${enable_dynamic_graphics}" = yes; then
+ if test "${ac_cv_func_dlopen}" = yes; then
diff --git a/astro/boinc-setiathome/files/pkg-install.in b/astro/boinc-setiathome/files/pkg-install.in
new file mode 100644
index 000000000000..c1815cc4bbdd
--- /dev/null
+++ b/astro/boinc-setiathome/files/pkg-install.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case "$2" in
+POST-INSTALL)
+ install -d -o %%BOINC_USER%% -g %%BOINC_GROUP%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
+ ln -s %%PREFIX%%/lib/boinc/%%SETI_BINARY%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
+ #ln -s %%PREFIX%%/lib/boinc/%%SETI_BINARY%%.so %%BOINC_HOME%%/projects/%%SETI_SITE%%
+ ;;
+esac
diff --git a/astro/boinc-setiathome/pkg-install b/astro/boinc-setiathome/pkg-install
deleted file mode 100644
index 29135ede5487..000000000000
--- a/astro/boinc-setiathome/pkg-install
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-case $2 in
-POST-INSTALL)
- chown %%BOINC_USER%%:%%BOINC_GROUP%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
- ;;
-esac
diff --git a/astro/boinc-setiathome/pkg-plist b/astro/boinc-setiathome/pkg-plist
index 37d5d443ab46..3dce4b4615a3 100644
--- a/astro/boinc-setiathome/pkg-plist
+++ b/astro/boinc-setiathome/pkg-plist
@@ -1,7 +1,6 @@
-@comment @unexec %D/boinc/boinc_client -detach_project %%SETI_SITE%%
+@comment @unexec %D/lib/boinc_client -detach_project %%SETI_SITE%%
lib/boinc/%%SETI_BINARY%%
@comment %%BOINC_GUI%%lib/boinc/%%SETI_BINARY%%.so
-@cd %%BOINC_HOME%%
-projects/%%SETI_SITE%%/app_info.xml
-projects/%%SETI_SITE%%/%%SETI_BINARY%%
-@comment %%BOINC_GUI%%projects/%%SETI_SITE%%/%%SETI_BINARY%%.so
+@unexec rm %%BOINC_HOME%%/projects/%%SETI_SITE%%/app_info.xml 2>&1 >/dev/null || true
+@unexec rm %%BOINC_HOME%%/projects/%%SETI_SITE%%/%%SETI_BINARY%% 2>&1 >/dev/null || true
+@comment %%BOINC_GUI%%@unexec rm %%BOINC_HOME%%/projects/%%SETI_SITE%%/%%SETI_BINARY%%.so 2>&1 >/dev/null || true