aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-16 06:17:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-16 06:17:25 +0000
commit865872ac50d3083e80b7c87cbeeea2df3d9c920c (patch)
tree52eb4b62c77db764fa9cdd0473e366ac2de37751 /astro/celestia/Makefile
parent3d110446093937ba865ef4c6d7222c84592b27b4 (diff)
- Update to version 1.6.0
- Rephrase IGNORE statement so it reads better - Make Lua support mandatory, build fails without it - Include support for Theora video capture - Minor Makefile cleanups Submitted by: Olexandr Sydorchuk (parts)
Notes
Notes: svn path=/head/; revision=239637
Diffstat (limited to 'astro/celestia/Makefile')
-rw-r--r--astro/celestia/Makefile52
1 files changed, 19 insertions, 33 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 495142620a05..f0cd9a29983d 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= celestia
-PORTVERSION= 1.4.1
-PORTREVISION= 9
+PORTVERSION= 1.6.0
CATEGORIES= astro
MASTER_SITES= SF
PKGNAMESUFFIX= -${CELESTIA_UI}
@@ -25,14 +24,12 @@ USE_XORG= x11 xt xext xmu xi
USE_GETTEXT= yes
WANT_GNOME= yes
-CONFIGURE_ARGS= --program-prefix=""
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
-CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|} # lol
+CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|}
.if ${CELESTIA_UI} == "glut"
CONFIGURE_ARGS+= --with-glut
@@ -45,58 +42,47 @@ CONFIGURE_ARGS+= --with-gnome
USE_GNOME+= libgnomeui
GCONF_SCHEMAS= celestia.schemas
.else
-IGNORE= invalid CELESTIA_UI value "${CELESTIA_UI}" -- valid values are ${UI_LIST}
+IGNORE= requires one of the <${UI_LIST}> values for CELESTIA_UI
.endif
.if ${CELESTIA_UI} == "gtk" || ${CELESTIA_UI} == "gnome"
USE_GNOME+= gnomehack
-LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext \
+ theora.0:${PORTSDIR}/multimedia/libtheora
STARTUP_NOTIFY= true
PLIST_FILES+= share/celestia/celestia-logo.png share/celestia/celestiaui.xml
.else
STARTUP_NOTIFY= false
.endif
-PORTDOCS= AUTHORS CelestiaKeyAssignments.txt ChangeLog \
- KbdMouseJoyControls.txt README TODO TRANSLATORS \
- coding-standards.html devguide.txt
+PORTDOCS= AUTHORS ChangeLog README
DESKTOP_ENTRIES="Celestia" \
"Explore space" \
"celestia.png" \
"celestia" \
- "Application;Astronomy;Science;Education;" \
+ "Application;Astronomy;Education;Science;" \
${STARTUP_NOTIFY}
-OPTIONS= LUA "Lua support" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LUA)
-USE_LUA= 5.0
-CONFIGURE_ARGS+= --with-lua
-CPPFLAGS+= -I${LUA_INCDIR}
-LDFLAGS+= -L${LUA_LIBDIR}
-.endif
+USE_LUA= 5.0+
+CONFIGURE_ARGS+= --with-lua LUA_CFLAGS=-I${LUA_INCDIR} \
+ LUA_LIBS=-L${LUA_LIBDIR} LUALIB_LIBS=-llua
pre-patch:
-.for o in -O2 -Wall -ffast-math -fexpensive-optimizations -fomit-frame-pointer
- @${REINPLACE_CMD} -e 's|${o}||g' ${WRKSRC}/configure
+.for o in O2 ffast-math fexpensive-optimizations fomit-frame-pointer
+ @${REINPLACE_CMD} -e 's|-${o}||g' ${WRKSRC}/configure
.endfor
+# Inhibit installation of copies of GPL (lots of them!)
@${REINPLACE_CMD} -e 's|COPYING||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|=.*COPYING_\*)|=| ; \
+ /KDE_DIST/s|COPYING_[^ ]* ||g' ${WRKSRC}/locale/Makefile.in
post-install:
- ${MKDIR} ${PREFIX}/share/pixmaps
${INSTALL_DATA} ${WRKSRC}/src/celestia/gtk/data/celestia.png \
${PREFIX}/share/pixmaps
-.for m in apollo cassini galileo gemini hubble iss marsglobalsurvr \
- marsodyssey mercury7 mir skylab
- ${INSTALL_DATA} ${WRKSRC}/models/${m}.3ds \
- ${PREFIX}/share/celestia/models
-.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>